TrafMeter :: Was ist TrafMeter?

Was ist TrafMeter?

Ihr Netzwerk ist mit dem Internet verbunden. Sind Sie aber sicher ob diese Verbindung auch effektiv genutzt wird? Oder brauchen Sie einfach ein Tool, das Ihnen ermöglicht den Traffic innerhalb oder ins Internet aufzuzeichnen?

TrafMeter ist eine Windows-Anwendung, die es erlaubt in Echtzeit den Traffic zu analysieren und anzuzeigen. Sie können es benutzen, um den Traffic ihres Computers zu überwachen (es ist kostenlos!) oder den Traffic aller PC's in ihrem LAN zu überwachen.

TrafMeter Features:

  • unlimitierte Anzahl von Filtern mit denen flexibel der interessante Traffic gefiltert und aufgezeichnet werden kann.
  • Innerhalb der Filter können Regeln definiert werden, die es erlauben den Traffic von einzelnen Hosts, ganzen Subnetzen oder Gruppen von Hosts zu erfassen. In den Regeln können auch die "Richtung" des Traffics oder aber auch die Protokolle definiert werden (ICMP,TCP,UDP,OSPF,etc).
  • TCP/UDP Port Filterung.
  • Die Regeln erlauben auch das Sperren von Internettraffic wenn Trafficlimits erreicht werden, wobei das Sperren flexibel definiert werden kann (Bsp: PC1 bei 100MB, PC2 bei 500 MB, PC3 wird nie gesperrt)!
  • Echtzeitdarstellung des Traffic in grafischer Darstellung. Jeder Filter kann eine eigene Farbe erhalten damit ein Administrator sofort erkennt, welcher Host welchen Traffic im Netzwerk verursacht.
  • Grafische Darstellung der Bandbreitennutzung der gefilterten Pakete in Echtzeit.
  • Report Erstellung via XML.
  • Erstellung von Berichten in verschiedene Datenquellen, z.B. XML oder weitverbreitete Datenbanken wie Microsoft SQL Server, Oracle, MySQL (in der Lite Version nicht verfügbar).
  • Nachverfolgung der Pakete in den verschiedenen Filtern anhand der MAC Adresse aus dem Ethernet Header und dem ToS (Type of Service) Feld im IP Header des Pakets. Diese Daten erlauben eine genaue Analyse des erfassten Traffics.
  • HTTP Host Header Logging (in der Lite Version nicht verfügbar).
  • Erfassen von unverschlüsselten VPN Paketen.
  • Firewall.

TrafMeter Webseite: www.trafmeter.com


TrafMeter :: License agreement

This End-User License Agreement ("EULA") is a legal agreement between you, either an individual or a single entity, ("LICENSEE") and Marel IT Solutions ("LICENSOR").

The license agreement includes computer software and may include associated media and online or electronic documentation ("SOFTWARE PRODUCT"). Please read the following terms and conditions before installing the SOFTWARE PRODUCT. By installing or using the SOFTWARE PRODUCT, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, do not install or use the SOFTWARE PRODUCT.

Copyright laws and international copyright treaties, as well as other intellectual property laws and treaties protect the SOFTWARE PRODUCT.

The SOFTWARE PRODUCT is licensed, not sold.

GRANT OF LICENSE
This EULA grants you the following rights:

USE AND COPY
You may install SOFTWARE PRODUCT on no more than one machine per valid license or as defined by purchased licenses. You may make other copies of the SOFTWARE PRODUCT for backup and archival purposes.

LICENSE TYPES
SOFTWARE PRODUCT is licensed on a RUN-TIME basis, which means, that for each machine on which SOFTWARE PRODUCT is installed, a valid run-time license must exist. Software licenses are provided as unique registration codes and/or serial numbers used to remove time-out settings in the software.

Single License
Allows installation and execution of SOFTWARE PRODUCT on a single machine per license.

Site License
Allows installation and execution of SOFTWARE PRODUCT on multiple machines within a single physical location (i.e. an office or data center location at a single physical address)

Enterprise License
Allows installation and execution of SOFTWARE PRODUCT on multiple machines in multiple locations throughout the licensed company's facilities.

RESTRICTIONS
Unregistered versions (shareware licensed copies) of the SOFTWARE PRODUCT may be used for an unlimited period but you are allowed to use only three traffic filters.

You must maintain all copyright notices on all copies of the SOFTWARE PRODUCT.

You may not sell copies of the SOFTWARE PRODUCT to third parties without express written consent of THE LICENSOR and under THE LICENSOR's instruction.

EVALUATION copies may distributed freely without charge so long as the SOFTWARE PRODUCT remains whole including but not limited to existing copyright notices, installation and setup utilities, help files, licensing agreement, run-time libraries, etc. and DOES NOT CONTAIN either valid serial numbers or illegal serial numbers. In executing such an act, or similar copyright or license violation, to the maximum extent permitted by applicable law you may be held liable for loss of revenue to THE LICENSOR or THE LICENSOR's representatives due to loss of sales or devaluation of the SOFTWARE PRODUCT or both.

You may not rent, lease, lend, copy, modify, sub-license or time-share the SOFTWARE PRODUCT. You may not reverse engineer, decompile or disassemble or otherwise alter the SOFTWARE PRODUCT or its documentation. You may not use a Registration Key Code issued to another user for use in conjunction with the SOFTWARE PRODUCT.

You may permanently transfer all of your rights under this EULA only in conjunction with a permanent transfer of your validly licensed copy of the product(s).

You must comply with all applicable laws regarding the use of the SOFTWARE PRODUCT.

You may not execute this software on more than ONE machine per valid license except as outlined under GRANT OF LICENSE - use and copy.

TERMINATION
THE LICENSOR may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE PRODUCT.

COPYRIGHT.
All title and copyrights and intellectual property rights in and to the SOFTWARE PRODUCT and any copies thereof are owned by THE LICENSOR.

NO WARRANTY
ANY USE OF THE SOFTWARE PRODUCT IS AT YOUR OWN RISK. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE AUTHOR DISCLAIMS ALL WARRANTIES AND CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NONINFRINGEMENT.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF, MIS-USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT, EVEN IF THE AUTHOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES AND JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

LIMITATION OF LIABILITY.
THE AUTHOR'S ENTIRE LIABILITY AND YOUR EXCLUSIVE REMEDY UNDER THIS EULA SHALL NOT EXCEED ONE DOLLAR (US$1.00).


TrafMeter :: TrafMeter anpassen!

TrafMeter anpassen!

Wir können TrafMeter Ihren Bedürfnissen anpassen. Anders gesagt: Wir können spezielle Features nach Bedarf einbauen. Die Kosten liegen bei nur $10 pro Stunde! Senden Sie uns ein Mail für weitere Informationen.


TrafMeter :: Versions

TrafMeter Versionen

TrafMeter ist in 3 verschiedenen Versionen erhältlich:

 | TrafMeter Freeware | TrafMeter Lite | TrafMeter
Traffic Erfassung | ja | ja | ja
Traffic Berichte | ja | ja | ja
Traffic Aufzeichnung in Datenbanken | abhängig von der Version | nein | ja
Paket Logging in Textdatei oder Datenbank | abhängig von der Version | nein | ja
Host Header Logging (erlaubt die Überprüfung der besuchten Webseiten) | abhängig von der Version | nein | ja
Anzahl der Filter | 3 | unlimitiert | unlimitiert
Kosten für Einzellizenz | 0 | 29 USD | 69 USD

Die neueste Version erhalten sie von der offiziellen Webseite: http://www.trafmeter.com

Anmerkung

  • Es kann stets nur ein TrafMeter Dienst auf einem PC zur gleichen Zeit laufen.


TrafMeter :: Wie kaufen?

Wie kaufen?

Nach der Installation haben Sie soviel Zeit wie Sie benötigen, um das Produkt ausgiebig zu testen. Die einzige Einschränkung ist die Limitierung auf 3 Filter in der Freeware Version. Um diese Limitierung zu entfernen, müssen Sie eine Lizenz erwerben.

Die schnellste Art ist der Erwerb via Kreditkarte. Einfach auf den BESTELLEN Link unten klicken. Nach spätestens 1-2 Tagen können Sie die Software einsetzen! Alternativen für den Kauf sind:

  • KREDITKARTE via TELEFAX (+43 5574 86012)
  • KREDITKARTE via TELEFON (+43 5574 86010)
  • VORAUSKASSE via SCHECK oder BANKÜBERWEISUNG (Formular zur Akontozahlung).

Alle oben aufgeführten Zahlungsarten können auch über SWREG abgewickelt werden.

 | Lite | Standard
Einzellizenz Erlaubt die Installation und Ausführung des Dienstes auf einem einzelnen Rechner. | $29 BESTELLEN | $69 BESTELLEN
Firmenlizenz Erlaubt die Installation und Ausführung des Dienstes auf mehreren Rechnern an einem einzelnen Ort (z.B. am Firmensitz oder in einem Hostingcenter). | $149 BESTELLEN | $345 BESTELLEN


TrafMeter :: Wie Sie uns erreichen

Wie Sie uns erreichen

Für Kommentare, Anregungen oder Fehlermeldungen die TrafMeter betreffen, schicken Sie bitte eine eMail an support@trafmeter.com

Wenn es sich um technischen Support handelt, fügen Sie ihrer Mail bitte folgende Dateien an (bitte die Dateien zippen bevor Sie diese an uns senden):

  • Datei "support.txt" aus dem TrafMeter Startverzeichnis
    (Standard: C:\Programme\TrafMeter\support.txt)
  • Anwendungslogs des TrafMeter Dienstes
    (Standard: C:\Programme\TrafMeter\Logs\Log*.txt)
  • Der verwendete Filtersatz
    (Standard: C:\Programme\TrafMeter\FilterSets\default.tmf)
  • zusätzliche Informationen zu ihrer Netzwerkkonfiguration sind ebenfalls nützlich

Postal address:
MAREL IT solutions
Rosenweg 3c
A-6923 Lauterach

Telefon +43(5574)86011
Telefax +43(5574)86012


TrafMeter :: Systemvoraussetzungen

Systemvoraussetzungen

  • 32 MB RAM
  • Microsoft Windows 98/ME/NT/2000/XP/2003
  • Microsoft Internet Explorer 5.0 oder höher


TrafMeter :: Einführung

Einführung

Es gibt viele Gründe um mit TrafMeter den Traffic im Netzwerk zu überwachen. z.B:

  • Die Netzwerkgeschwindigkeit zwischen 2 Hosts im Netzwerk zu testen um "Flaschenhälse" aufzuspüren
  • Zu ermitteln, welche Arbeitsstation den grössten Internettraffic verursacht
  • Um regelmäßige Berichte bzgl. der Internetnutzung zu erhalten

Wie arbeitet TrafMeter?

TrafMeter erfasst die über eine Netzwerkarte laufenden Pakete, analysiert diese anhand von Filterregeln und erstellt in Abhängigkeit der Filterkonfiguration die Trafficdaten. Eine äußerst flexible Filterengine erlaubt es dem Administrator nur jenen Traffic zu erfassen, der wirklich von Interesse ist.

Der Filtersatz

Der Filtersatz ist der Kern von TrafMeter. Der Filtersatz enthält einerseits die Filter mit den Regeln, andererseits zusätzliche Einstellungen für das Erfassen des Traffics, Erstellung von XML Berichten, das Erfassen der Daten in eine Datenbank, etc. Der Filtersatz wird in einem XML File gespeichert und hat die Erweiterung .tmf. Solange der Filtersatz nicht an eine bestimmte Netzwerkkarte gebunden ist, kann der Filtersatz von verschiedenen Arbeitsstation im Netzwerk genutzt werden.

Die Filter

Jeder Filter kann eine unlimitierte Anzahl von Regeln enthalten. Ausserdem besitzt jeder Filter einen 64-Bit breiten Zähler für gesendete und empfangene Bytes und einen unabhängigen Paketsammler. Die Zähler werden erhöht, sobald eine Regel im Filtersatz existiert, die dem verarbeiteten Paket entspricht.

Die Regel

Die Regel ist die unterste Ebene in der TrafMeter Hierarchie. Die Regel beinhaltet die Definition ob das Paket dieser Regel entspricht oder nicht.


TrafMeter :: Lieferumfang

Lieferumfang

Der TrafMeter Lieferumfang enthält mehrere Programme:

  • TrafMeter Dienst (trafsvc.exe) - der TrafMeter Kern. Der Dienst ermöglicht das Erfassen und Analysieren der Netzwerkpakete, erstellt die Zähler und erzeugt die Berichte. Der TrafMeter Dienst läuft als Win32-Standard-Anwendung oder als echter Windows NT/2000/XP/2003 Dienst (somit ist kein Userlogin für das Starten der Trafficverarbeitung nötig).
  • TrafMeter Administrationskonsole (trafadmin.exe) - Mit diesem Tool wird der TrafMeter Dienst konfiguriert. Es enthält den Filtersatz Editor, die Echtzeitgrafik für die Darstellung der erfassten Pakete, einen Viewer für die TrafMeter Diensteevents, etc.
  • TrafMeter Dienste Monitor (trafmonitor.exe) zeigt den Status des Dienst an und befindet sich als kleines Symbol im SysTray
  • Tool für das Zurücksetzen der Zähler (trafreset.exe) - erlaubt das Zurücksetzen der Trafficzähler. TrafReset.exe kann manuell gestartet werden oder auch mit dem Windows Zeitplandienst.

TrafMeter installiert alle nötigen Dateien und bittet um einen Reboot nach erfolgreicher Installation. Der Rechner muss neu gestartet werden, bevor TrafMeter genutzt werden kann.


TrafMeter :: TrafMeter Installationsanleitung

TrafMeter Installationsanleitung

Diese Anleitung hilft Ihnen, den optimalen Ort für die TrafMeter Installation zu finden, um den Datenverkehr zwischen ihrem Netzwerk und dem Internet zu ermitteln.

Einfache Netzwerk Konfiguration

Ein kleines bis mittleres Netzwerk besteht meist aus einem einzigen Ethernet Segment an das alle Computer angeschlossen sind. Die Verbindung wird meist über einen sogenannten Ethernet Hub realisiert. Das Netzwerk ist über einen Router/Gateway/Firewall mit dem Internet verbunden (Bild 1.).

Bei dieser Konfiguration müssen Sie TrafMeter auf einem der Computer, der am Hub angeschlossen ist, installieren und den promiskuitiven Modus aktivieren.

Wenn der Gateway ein Windows-Computer mit Proxy-Server Software (z.B. Microsoft ISA Server, WinRoute, WinGate, etc) ist, können Sie TrafMeter auch auf diesem Computer installieren.

geswitchte Netzwerke

Das im Bild 1 beschriebene Netzwerk verwendet einen "nicht switchenden" Hub um die Computer mit dem Router zu verbinden. Somit hat TrafMeter Zugriff auf alle Daten, die über das Netzwerk laufen.

In einem geswitchten Netzwerk wird eine sogenannter Ethernet Switch verwendet, um das Netzwerk zu segmentieren. Dies verringert die Netzwerklast erheblich und verhindert Kollisionen mit Datenpaketen von Rechnern im Netzwerk, die Daten anderer Rechner im Netzwerk überhaupt nicht benötigen.

Wenn ein "nicht managbarer" Switch verwendet wird, kann TrafMeter nicht einfach auf einem Computer installiert werden, der mit diesem Switch verbunden ist. Es wird ein zusätzlicher Hub benötigt, der zwischen dem Switch und dem Router geschaltet wird um den Datenverkehr erfassen zu können. Siehe Bild 3.

Wenn ein "managebarer" Switch verwendet wird, kann meist ein sogenannter "monitor" oder "spanning" Port definiert werden, an den der gesamte Datenverkehr weitergeleitet wird. Wenn an diesen Port ein Computer angeschlossen wird auf dem TrafMeter installiert ist, kann mit aktiviertem promiskuitiven Modus der Datenverkehr erfasst werden. Siehe Bild 4.


TrafMeter :: Verbinden und Konfigurieren

Mit dem Dienst verbinden und konfigurieren

TrafMeter besteht aus mehreren Programmen. Der TrafMeter Dienst beinhaltet Konfigurationsdaten um den Traffic verarbeiten zu können. Der Dienst arbeitet im Hintergrund und besitzt keine Fenster. Um diese Konfigurationsdaten ändern zu können, müssen Sie die Administrationskonsole starten und sich mit dem Dienst über das Menü "Dienst" -> "Verbinden..." oder das Anklicken des Symbols [image] in der Toolbar verbinden.

Note

  • Das Passwort ist standardmäßig leer. Es wird empfohlen, ein Passwort zu definieren.
  • Der TrafMeter Dienst erlaubt die Remoteadministration. Somit können Sie einen TrafMeter Dienst auch über ein Netzwerk verwalten.
  • Der TrafMeter Dienst belegt TCP Port 7643 für eingehende Verbindungen.
  • Aus Sicherheitsgründen akzeptiert der TrafMeter Dienst eingehende Verbindungen einer Administrationskonsole nur auf einer einzelnen spezifizierbaren IP Adresse. Die Adresse muss auf dem PC vorhanden sein. Siehe auch Optionen im Menü Extras der Administrationskonsole.
  • Der Dienst kann nur von einer Administrationskonsole zur selben Zeit modifiziert werden.


TrafMeter :: Netzwerkadapter auswählen

Netzwerkadapter (NIC) auswählen

Die Auswahl des Netzwerkadapters ist ein wichtiger Punkt in der Dienstekonfiguration. Dafür steht eine Dialogbox zur Verfügung, wenn die Administrationskonsole mit einem TrafMeter Dienst verbunden ist und keine Verarbeitung läuft.

Anmerkung

  • Es ist möglich, mehrere Adapter gleichzeitig auszuwählen.
  • Für bessere Performance sollten Adapter deren Traffic nicht erfasst wird, nicht ausgewählt werden.
  • Wenn der Netzwerkadapter mehrere IP Adressen besitzt, wird trotzdem nur eine IP Adresse angezeigt.
  • Netzwerkadapter die auf dem Realtek RTL8139 Chip basieren, können als "NDIS 5.0" angezeigt werden. Dies hat keine Auswirkungen auf die Funktionsfähigkeit von TrafMeter.


TrafMeter :: Traffic Verarbeitung

Traffic Verarbeitung

Der TrafMeter Dienst unterscheidet zwischen 2 verschiedenen Zuständen: eine laufende und keine Verarbeitung. Diese Zustände können von der Administrator Konsole verändert werden. Die Verarbeitung kann gestartet werden, wenn ein Netzwerkadapter ausgewählt wurde und mindestens ein Filter im Filtersatz enthalten ist.

Die Verarbeitungszustände ändern

  • Um die Verarbeitung zu starten, benutzen Sie das Menü "Verarbeitung" -> "Starten" in der Administrationskonsole oder klicken Sie einfach auf den Button [image] in der Toolbar
  • Verwenden Sie das Menü "Verarbeitung" -> "Anhalten" in der Konsole oder klicken Sie einfach auf [image] in der Toolbar

Anmerkung

  • Wird der TrafMeter Dienst gestartet, versucht dieser selbständig die Verarbeitung zu beginnen.


TrafMeter :: Den Dienst überwachen

Den TrafMeter Dienst überwachen

TrafMeter arbeitet als Dienst im Hintergrund und hat deshalb keine Fenster um den Status der Verarbeitung anzuzeigen. Es gibt 2 Wege, den Status zu überprüfen:

Über den TrafMeter Dienst Monitor

Dieser zeigt den aktuellen Status des TrafMeter Dienstes im Systray an.

TrafMeter verarbeitet den Traffic
Die Verarbeitung wurde gestoppt oder pausiert
TrafMeter verarbeitet keine Pakete
Der TrafMeter Dienst kann nicht erreicht werden

Über einen Webbrowser

Starten Sie ihren Webbrowser und verwenden Sie die URL http://<ip_des_trafmeter_rechners>:7643. Folgendes wird angezeigt:


TrafMeter :: Architektur

Verarbeitung der erfassten Pakete in TrafMeter

Es existieren drei Ebenen der Verarbeitung: der Filtersatz, die Filter und die Regeln.

Die Regel Ebene

Das Paket muss allen Definitionen der Regel entsprechen damit es von der Regel akzeptiert wird. Dieser Fall wird "Rule Match" und die Regel in diesem Fall "Matched Rule" genannt.

Die Filter Ebene

Ein Filter kann beliebig viele Regeln enthalten. Das Paket muss mindestens einer Regel im Filter entsprechen, damit das Paket dem Filter entspricht und die im Filter definierten Aktionen ausgeführt werden. Die Regeln werden der Reihe nach abgearbeitet bis eine Regel entspricht. Wenn eine Regel im Filter entspricht, werden "dahinterliegende" Regeln im selben Filter nicht mehr verarbeitet. Wenn die Regel die Aktion "Zählen" oder "Zählen & Durchlassen" besitzt, wird der entsprechene Zähler erhöht. Es wird die Gesamtlänge des Pakets hinzugezählt.

Die Filtersatz Ebene

Das erfasste Paket wird von allen Filtern im Filtersatz der Reihe nach verarbeitet. Der nächste Filter wird aufgerufen, wenn:

  • das erfasste Paket keiner Regel im vorherigen Filter entspricht
  • die Regel die enstpricht die Aktion "Zählen" definiert hat

TrafMeter beendet die Verarbeitung des Pakets, wenn:

  • die Regel die enstpricht die Aktion "Durchlassen (nicht zählen) oder "Zählen & Durchlassen" definiert hat
  • die Regel die entspricht die Aktion "Verweigern" definiert hat. In diesem Fall wird das Paket verweigert. Diese Aktion ist nur im "Aktiven Verarbeitungsmodus" verfügbar. Im passiven Modus kann die Aktion "Durchlassen" verwendet werden um ein ähnliches Verhalten zu erreichen.


TrafMeter :: Aufzeichnung der Anwendungsereignisse

Aufzeichnung der Anwendungsereignisse

Der TrafMeter Dienst erzeugt Ereignis- und Fehlermeldungen und speichert diese gleichzeitig in 2 verschiedenen Zielen: die Windows Ereignisanzeige und in eine Textdatei.

Aufzeichnung in Windows Ereignisanzeige

Die Windows Ereignisanzeige ist eine Betriebssystemkomponente und steht in den Betriebssystemen Windows NT/2000/XP/2003 zur Verfügung. Diese Komponente beinhaltet einen Viewer, eine Suchmaschine und erlaubt das Anzeigen der Ereignisse über Remoteverbindungen. Um die TrafMeter Ereignisse anzuzeigen, müssen Sie den Viewer "Ereignisanzeige" starten (Systemsteuerung -> Verwaltung) und wählen Sie die Anwendungsereignisse. Die TrafMeterereignisse werden mit der Quelle "TrafSvc" geschrieben.

Aufzeichnung in Textdatei

Dies zeichnet die Ereignisse direkt in eine Textdatei im benutzerdefinierbaren Verzeichnis auf (Standard: %programfiles%\TrafMeter\Logs). Der Dateinamen wird anhand der Vorlage "Log_yyyy_mm.txt" aus dem aktuellen Datum generiert (yyyy ist die vierstellige Jahreszahl und mm ist der zweistellige Monat: 01 to 12). Wenn Sie den technischen Support kontaktieren, sollten Sie die entsprechende Datei beifügen.

Das Verzeichnis können Sie über die "Optionen" in der Administrationskonsole abändern.


TrafMeter :: Aufzeichnung der verweigerten Pakete

Aufzeichnung der verweigerten Pakete

Im aktiven Verarbeitungsmodus kann TrafMeter Pakete verweigern, wenn die Aktion "Verweigern" gewählt ist. Alle verweigerten Pakete werden in einer Textdatei im benutzerdefinierten Verzeichnis (Defaulteinstellung: %programfiles%\TrafMeter\Logs) gespeichert. Der Dateinamen ist abhängig vom Datum und wird aus der Vorlage "DeniedPkt_yyyy_mm.txt" (yyyy ist das vierstellige Jahr und mm ist der zweistellige Monat: 01 bis 12) erzeugt.

Sie können das Verzeichnis für die verweigerten Pakete im Menü "Extras" -> "Optionen" -> "Verzeichnisse" der Administrationskonsole ändern.

Sie können auch verschiedene Stufen für die Behandlung verweigerter Pakete einstellen (still, normal und erweitert). Details hier.


TrafMeter :: TrafMeter als Firewall nutzen

TrafMeter als Firewall nutzen

Obwohl TrafMeter als Traffic Monitoring Software verkauft wird und zumeist mit einer separaten Firewall installiert wird, hat Trafmeter ebenfalls die Möglichkeit Pakete zu verweigern, da TrafMeter den gleichen Kern wie viele Firewalls besitzt.

Um diese Möglichkeiten zu zeigen, sollten wir mal einen typischen Anwendungsfall betrachten, bei dem TrafMeter die Aufgaben einer Firewall übernehmen kann. Ein Beispiel: Wir haben ein Netzwerk mit einem Gateway Server mit Windows 2003 Server als Betriebssystem und dem Routing and Remote Access Service (RRAS), der das NATing erledigt. Welche Pakete müssen nun verweigert werden, um den Gateway gegen Hacker zu schützen? Eine Lösung wäre die Einschränkung des Zugriffs auf alle Netzwerkdienste auf dem Gateway von allen nicht vertrauenswürdigen Netzwerken.

eingehende TCP-Verbindungen

Auf Basis des TCP Protokolls initialisiert ein Client eine Verbindung mit dem Server in dem er ein erstes TCP Paket mit dem SYN Flag sendet. Um eingehende Verbindungen zu unterbinden, benötigen wir also eine Regel die TCP Pakete mit einem SYN Flag sperrt, die von einem nicht vertrauenswürdigen Netzwerk kommen. Das schützt alle Netzwerkdienste auf dem Gateway, basierend auf dem TCP Protokoll.

eingehende UDP-Verbindungen

Beim UDP Protokoll sieht es etwas anders aus. Hier ist es schwieriger, anhand der Header Analyse den Client bzw. Server ausfindig zu machen. Grundsätzlich benutzen aber auf UDP basierende Netzwerkdienste die Ports von 1 bis 1024. Wenn nun UDP Pakete verweigert werden, die als Zieladresse die Gatewayadresse besitzen und die Ports im Bereich 1 bis 1024 angesprochen werden, wird dies eingehende UDP Verbindungen verhindern. Wenn Dienste Ports über 1024 verwenden, sollten zusätzliche Regeln erstellt werden.

ICMP-Pakete

Typischerweise beinhalten ICMP Pakete nicht das selbe Risio wie TCP oder UDP. Die meisten Firewalls blockieren trotzdem auch eingehende ICMP Echo Request Pakete um den Gateway vor Network Scannern zu verbergen. Wenn gewünscht, kann TrafMeter ebenfalls ICMP Pakete verweigern.

Zusammenfassung

Um Trafmeter als Firewall zu nutzen, muss ein einzelner Filter erstellt werden. Dieser Filter muss an erster Stelle in der Liste stehen und folgende Regeln enthalten:

Filter 1. firewall
N | IP Protokoll Typ | Ursprungsadresse | Ursprungsport | Zieladresse | Zielport | Beide Richtungen | Aktion | Zusätzliche Optionen
1 | TCP | IP Adressen des WAN | Jeder | Mein Computer | Jeder | Nein | Verweigern | SYN
2 | UDP | IP Adressen des WAN | Jeder | Mein Computer | 1-1024 | Ja | Verweigern |
3 | ICMP | IP Adressen des WAN |  | Mein Computer |  | Nein | Verweigern | Echo request

Anmerkung

  • Es muss der aktiver Verarbeitungsmodus gewählt werden, sonst ist das Verweigern von Paketen nicht möglich.
  • Sie sollten passives FTP verwenden wenn eingehende TCP Pakete mit SYN Flag verweigert werden.
  • Für Dienste die UDP Port über 1024 verwenden, müssen zusätzliche Regeln erstellt werden.
  • Verweigerte Pakete werden in %Program Files%\TMeter\Logs geloggt..


TrafMeter :: Filter Manager

Filter Manager

Der Filter Manager erlaubt das Hinzufügen, Bearbeiten oder Löschen der Filter sowie die Abänderung der Reihenfolge der Filter.


TrafMeter :: Filter Editor

Filter Editor

Mit dem Filter Editor können sämtliche Parameter betreffend den Filtern konfiguriert werden. Sie können Regeln hinzufügen, ändern oder löschen. Ein Filter kann eine unlimitierte Anzahl von Regeln enthalten. Mit dem Paket Logging Feature können Pakete in eine Textdatei oder in eine Datenbank geschrieben werden. Details finden sie hier

Den Filter Editor können Sie vom Filter Manager starten.

Anmerkung

  • Um die maximale Performance zu erreichen, sollten Sie jene Regeln, die am meisten entsprechen, auf der Liste ganz vorne stehen.


TrafMeter :: Regel Editor

Regel Editor

Folgende Werte können im Regel Editor definiert werden:

Regel Beschreibung

Beschreibung der Regel (maximal 100 Zeichen). Kann leer bleiben.

IP Protokoll

Hier kann über den Namen oder die Nummer ein IP Protokoll definiert werden. Siehe dazu auch die Information IP Protokoll Nummern.

Ursprung und Ziel

Mit diesen Werten kann auf die IP Adresse in den Paketen geprüft werden. Bei TCP und UDP Paketen, kann noch zusätzlich der Port als Kondition angegeben werden.

Richtung

  • Wenn diese Option deaktiviert ist, müssen die Ursprungs- und Zieladresse des IP Paketes exakt der Regel enstprechen. Dann spricht man von einer direkten Übereinstimmung.
  • Wenn diese Option aktiviert ist, können die Ursprungs- und Zieladresse auch exakt umgekehrt sein, um der Regel zu entsprechen. Dann spricht man von einer indirekten Übereinstimmung.

Achtung! Die Option "Richtung" ist standardmäßig aktiviert. Solange Sie nicht exakt wissen was Sie tun, lassen Sie diese Einstellung unverändert.

TCP Optionen (nur für TCP Protokoll)

Dies erlaubt die Erfassung des ersten Paketes einer neuen TCP Verbindung (laut TCP Spezifikationen ist dies das Paket mit dem SYN Flag und ohne ACK Flag). Diese Option ist nützlich um Firewall Regeln zu erstellen um beispielsweise eingehende TCP Verbindungen zu verhindern. Diese Option ist nur in eine Richtung möglich, das Feature "Richtung" wird automatisch disabled.

ICMP Optionen (nur für ICMP protocol)

Dies erlaubt die Überprüfung des Typs jeden erfassten ICMP Pakets. Wenn das erfasste Paket z.B. ein "ICMP Echo Request" ist, entspricht die Regel. Damit kann ebenfalls leistungsfähige Firewallfunktionalität ermöglicht werden.

Aktion

Die "Aktion" definiert, was TrafMeter mit dem Paket machen soll, wenn das Paket der Regel entspricht.

  • Zählen - Die Trafficzähler des Filters werden erneuert und das Paket wird vom nächsten Filter (nicht Regel!) verarbeitet
  • Durchlassen (nicht Zählen) - Die Trafficzähler verbleiben unverändert und das Paket wird anschließend von keiner Regel und von keinem Filter mehr verarbeitet
  • Zählen und Durchlassen - Die Trafficzähler werden erneuert aber das Paket wird wie bei der obigen Option anschließend von keiner Regel und keinem Filter mehr verarbeitet
  • Verweigern - Die Trafficzähler verbleiben unverändert und das Paket wird von der internen Firewall verweigert (nur im aktiven Verarbeitungsmodus verfügbar)

In Tabellenform sieht das folgendermaßen aus:

Aktion | Die Zähler werden erhöht | Das Paket wird vom nächsten Filter verarbeitet | Das Paket wird von der Firewall verweigert
Zählen | Ja | Ja | Nein
Durchlassen (nicht Zählen) | Nein | Nein | Nein
Zählen und Durchlassen | Ja | Nein | Nein
Verweigern | Nein | Nein | Ja
sämtliche Regeln im Filter entsprechen nicht | Nein | Ja | Nein

Option "Das Paket muss ein"

Dies definiert, ob das Paket von einem vorhergehenden Filter gezählt oder nicht gezählt wurde. Diese Option ist nützlich, um das doppelte Zählen von Paketen zu vermeiden.

ToS (Type of Service) Feld

Dies ermöglicht nach Inhalten des ToS Feldes im IP Header zu filtern. Nähere Informationen zu ToS finden Sie hier.

Trafficzähler Eigenschaften

Hiermit können Limitierungen für Traffic definiert werden (im aktiven Verarbeitungsmodus möglich). Siehe auch Beispiel 6.

zeitbasierende Eigenschaften

Hiermit kann ein Zeitbereich definiert werden, in dem die Regel gültig ist .

Der Regel Editor kann vom Filter Editor aus gestartet werden.


TrafMeter :: LAT

Lokale Adresstabelle (LAT)

Die LAT sollte ausschließlich die IP Adressen ihres lokalen Netzwerkes (LAN) enthalten.

Mit der LAT ist es möglich Regeln zu erstellen, die ausschließlich den Traffic innerhalb des Netzes erfassen oder es erlauben, den gesamten Traffic mit Ausnahme des LAN-Traffics zu erfassen (= Traffic zwischen dem LAN und dem Internet). Wenn die LAT definiert ist, enthalten die Definitionen "IP Adressen des LAN" alle Pakete mit Adressen innerhalb des LAN. Die Definition "IP Adressen des WAN" enthalten dann sämtliche IP-Adressen mit Ausnahme der Adressen des LAN.

Wenn die LAT leer ist, enthält die Regel "IP Adressen des WAN" sämtliche IP-Adressen (entspricht somit "alle IP-Adressen"). Die maximale Anzahl an LAT Einträgen ist nicht limitiert. Die Verarbeitungsgeschwindigkeit von TrafMeter wird von der Anzahl der LAT Einträge nicht beeinflusst, da TrafMeter einen sehr schnelle Algorithmus zur Suche eine IP-Adresse in der LAT besitzt.

LAT importieren

Die IP Adressen können von einer externen Textdatei importiert werden. Jede Zeile muss 2 IP-Adressen enthalten, die den Anfang und das Ende des Netzes definieren. Diese beiden IP-Adressen müssen mit einem Leerzeichen getrennt werden. Beispiel:

192.168.1.1 192.168.1.255
192.168.50 192.168.5.255
192.168.80.2 192.168.80.63


TrafMeter :: Datenbank Verbindungsstring (OLE DB Connection string)

Datenbank Verbindungsstring (OLE DB Connection string)

TrafMeter kann die Header der Pakete oder die Zählerstände in eine Datenbank aufzeichnen. Um mit einer Datenbank zu kommunizieren, verwendet TrafMeter die ADO (ActiveX Data Objects) Komponente der Windows Betriebssysteme. Den dafür nötigen Verbindungsstring müssen Sie definieren, wenn Sie Daten aus TrafMeter in eine Datenbank speichern wollen.

Dieser String enthält alle Informationen für den Verbindungsaufbau zur Datenbank. Jede Datenbank benötigt spezische Parameter die Sie definieren müssen. Manche Datenbanken erlauben auch die Definition von Optionen über diesen Befehl. Ein solcher Verbindungsbefel kann folgendermaßen aussehen:

SQLOLEDB.1; Password=TrafMeter; Persist Security Info=True;
User ID=TrafMeter; Initial Catalog=traffic; Data Source=SERVERNAME

Ein solcher Befehl kann auch in einer Datei mit spezieller Endung gespeichert werden. Diese Datei wird "User Data Link file" (UDL) genannt und hat die Erweiterung .udl. Für diese Dateien steht ein eigener Assistent zur Verfügung. Erstellen Sie einfach eine leere Datei mit der Endung .udl und doppelklicken Sie diese. Dann können Sie die Parameter über den Assistenten erzeugen. In TrafMeter können Sie direkt auf diese UDL Datei verweisen:

File Name=c:\DataLinks\trafmeter.udl

Ändert sich die Datenbank oder Netzwerkkonfiguration, können Sie mit dem Assistenten die Änderungen definieren und müssen in TrafMeter keine Modifikationen vornehmen.

Siehe auc:

  • HOWTO: Einen OLE DB Verbindungsstring für Microsoft SQL Server erstellen
  • HOWTO: Einen OLE DB Verbindungsstring für Access 97/2000/XP Datenbanken erstellen
  • HOWTO: Einen OLE DB Verbindungsstring für MySQL erstellen

Anmerkung

  • Um die installierte ADO Version zu ermitteln, starten Sie die Administrationskonsole, öffnen Sie das Menü "Hilfe" -> "Über..." und klicken Sie auf "Support-Informationen".
  • Es wird dringend empfohlen, die ADO Version 2.7 oder höher zu verwenden. Die aktuelle ADO Version (auch MDAC genannt) kann kostenlos von folgender Internetseite geladen werden: http://www.microsoft.com/data


TrafMeter :: XML Traffic Berichte

XML Traffic Berichte

XML Traffic Reports sind der einfachste Weg um Traffic Berichte für fixe Perioden zu erstellen.

Warum XML ?

XML ist eine Standardsprache für die Strukturierung und Beschreibung von Daten die auch von anderen Anwendungen genutzt werden kann. Die Stärke von XML ist die Trennung von Daten und Benutzeroberfläche.

Mit welcher Anwendung lassen sich die Traffic Berichte am besten anzeigen?

Microsoft Internet Explorer.

Wie funktioniert das?

Dieser Bericht fasst die monatlichen Trafficdaten zusammen. Wenn ein neuer Monat beginnt, wird ein neues XML File automatisch erstellt. Die Dateinamen basieren auf der vierstelligen Jahreszahl und der zweistelligen Monatszahl. Beispielsweise beinhaltet die Datei "2003_09.xml" die Daten des Monats September 2003. Ausserdem erzeugt TrafMeter noch eine zusätzliche Datei "CurrentMonth.xml". Diese Datei ist eine Kopie der aktuellen Monatsdatei.

Ein Beispiel eines monatlichen XML Traffic Berichts finden Sie hier. Dieser Bericht zeigt den Traffic des Filters mit der id=15. Wie Sie sehen, zeigen die Zähler 2518192 (gesendete Bytes) und 12315902 (empfangene Bytes) für den gesamten Monat August 2003. Daneben beinhaltet der Bericht auch die täglichen Zählerstände. z.B. ist ersichtlich, dass am 22 August 2003 insgesamt 677994 Bytes gesendet und 3510996 Bytes empfangen wurden.

Um die Darstellung der Daten abzuändern, siehe XSL Formatierung für monatliche XML Traffic Reports.

Siehe auch:

  • XSL Formatierung für XML Traffic Berichte


TrafMeter :: XSL Formatierung für XML Traffic Berichte

XSL Formatierung für XML Traffic Berichte

XSL steht für Extensible Stylesheet Language. XSL ist das, was bei HTML die Cascading Stylesheets (CSS) sind. XML enhält nur Daten und keine Informationen, wie diese Daten angezeigt werden sollen. Mit einem entsprechenden XSL kann nun definiert werden, wie die Daten angezeigt werden sollen: Als HTML, PDF, RTF, GIF oder irgendeinem anderen unterstützten Format.

Hier ein Beispiel einer von TrafMeter erzeugten XML Datei:

<?xml version="1.0"?>
<TrafficReport>
    <Filter Id="1">
        <Name>ICMP</Name>
        <Sent>7224</Sent>
        <Recv>7224</Recv>
    </Filter>
    <Filter Id="2">
        <Name>TCP</Name>
        <Sent>3566</Sent>
        <Recv>8967</Recv>
    </Filter>
    <LastModified>November, 26 2002 11:19:14</LastModified>
</TrafficReport>

Wenn Sie die Datei mit dem Microsoft Internet Explorer öffnen, sieht es folgendermaßen aus:

Das ist nicht sehr benutzerfreundlich. Um dies zu ändern, erzeugen wir eine XSL Formatierung in einer seperaten traffic.xsl Datei. Die Datei finden Sie hier.

Als nächstes gügen wir den Aufruf der XSL Date als Vorspann in die XML Datei hinzu:

<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="traffic.xsl"?>
<TrafficReport>

... und wir bekommen bei Aufruf der XML Datei im Microsoft Internet Explorer ein viel benutzerfreundlichere Ansicht der Daten:

Wie Sie den monatlichen XML Traffic Bericht mit XSL formatieren, finden Sie hier.


TrafMeter :: Beispiel für die XSL Formatierung eines XML Traffic Berichts

Beispiel für die XSL Formatierung eines XML Traffic Berichts

<?xml version="1.0"?>
<xsl:template xmlns:xsl="uri:xsl">
  <HTML>
    <BODY>
      <H3>Your company name - Daily traffic report</H3>
<table cellspacing="0" cellpadding="5" border="1">
<tr>
    <td STYLE="font-family:Arial; font-size:12">
      Id
    </td>
    <td STYLE="font-family:Arial; font-size:12">
      Name
    </td>
    <td STYLE="font-family:Arial; font-size:12">
      Sent
    </td>
    <td STYLE="font-family:Arial; font-size:12">
      Recv
    </td>
</tr>

  <xsl:for-each select="TrafficReport/Filter">
<tr>
    <td STYLE="font-family:Arial; font-size:12">
      <xsl:value-of select="@Id"/>
    </td>
    <td STYLE="font-family:Arial; font-size:12">
      <xsl:value-of select="Name"/>
    </td>
    <td STYLE="font-family:Arial; font-size:12">
      <xsl:value-of select="Sent"/>
    </td>
    <td STYLE="font-family:Arial; font-size:12">
      <xsl:value-of select="Recv"/>
    </td>

</tr>
  </xsl:for-each>

</table>

<p> <br>
<i>Last Modified:
<xsl:value-of select="TrafficReport/LastModified"/>
</i> </br></p>

    </BODY>
  </HTML>
</xsl:template>


TrafMeter :: Beispiel für die XSL Formatierung eines monatlichen XML Traffic Berichts

Beispiel für die XSL Formatierung eines monatlichen XML Traffic Berichts

Dieses XSL Style Sheet (month.xsl) wurde für den monatlichen XML Traffic Bericht erstellt und erlaubt:

  • Die Zählerstände in einer auswählbaren Einheit (Byte, KB, MB, GB) zu betrachten.
  • Die Zählerstände für alle Filter und den gesamten Monat zu betrachten
    • .
  • Die Zählerstände für alle Filter und für einen bestimmten Tag zu betrachten
    • .
  • Die Zählerstände für einen bestimmten Filter für einen bestimmten Zeitraum zu betrachten.

Hier ist die gezippte month.xsl (3kb).

Beispiel für die Ausgabe der monatlichen XML Datei mit diesem XSL Style Sheet:


TrafMeter :: Traffic Logging in eine Datenbank

Traffic Logging in eine Datenbank (in der Lite Version nicht verfügbar)

Dies erlaubt das Aufzeichnen der Trafficdaten in eine Datenbank und ermöglicht somit den Aufbau eines schnellen und skalierbaren Accountingsystems für ihrer Benutzer. Um dieses Feature zu nutzen, muss folgendes definiert werden:

  • Datenbank Verbindungsstring
  • Die Datenbanktabelle für das Traffic Logging erstellen
  • Den Wert für "Traffic Samples" definieren

Was ist der "Traffic Samples" Wert?

Mit diesem Wert wird definiert, in welchen Abständen ein sogenanntes "Traffic Sample" erstellt wird. Ein solches Sample beinhaltet den Traffic eines Filters während des Zeitintervalls. Diese Samples werden von Backbone Carrier Provider benutzt, um den Bandbreitenverbrauch zu berechnen ("95% Methode").

Wie schreibt TrafMeter die Werte in die Datenbank?

  1. Der aktuelle "ts" Wert für das Sample wird aus 2 Werten ermittelt: 1) aus dem benutzerdefinierten "Traffic Samples" Wert und 2) aus der aktuellen Systemzeit. Beispiel: Wenn die aktuelle Zeit 19:49 am 22 August 2003 ist, ergeben sich abhängig vom "Traffic Samples" Wert folgende aktuellen "ts" Werte:

    benutzerdefinierter "Traffic Samples" Wert | "ts" Wert (im ymmddhhmi Format)
    1 Minute | 308221949
    5 Minuten | 308221945
    15 Minuten | 308221945
    30 Minuten | 308221930
    1 Stunde | 308221900
    2 Stunden | 308221800
    1 Tag | 308220000

  2. Der Befehl "SELECT * FROM traffic_table WHERE ts=308222145" wird ausgeführt und der selektierte Wert in einem temporären Speicherort gespeichert.
  3. Die seit der letzten Datenbankaktualisierung ungesicherten Werte werden dem temporären Zähler hinzugezählt.
  4. Die Werte des temporären Zählers werden in die Datenbank geschrieben.


TrafMeter :: Datenbanktabelle für das Traffic Logging

Datenbanktabelle für das Traffic Logging

Um die Traffic Zähler in eine Datenbank zu schreiben, benötigen Sie eine Tabelle mit mindestens den folgenden Feldern:

N | Feld Name | Feld Typ | Beschreibung
1. | filterid | smallint | Filter ID (von 1 bis N. N ist die Anzahl der Filter im Filtersatz)
2. | ts | int | Start des Zeitintervalls im Format ymmddhhmi. Beispiel: der Werte 308220945 entspricht 09:45 am 22 August 2003
3. | sent | bigint | Zähler der gesendeten Bytes
4. | recv | bigint | Zähler der empfangenen Bytes

Das folgende Skript erstellt Ihnen die notwendigen Tabellen im Microsoft SQL Server:

CREATE TABLE [dbo].[traffic] (
   filterid smallint NOT NULL,
   ts int,
   sent bigint, recv bigint)

Dieses Skript funktioniert auch auf einer MySQL Datenbank:

CREATE TABLE traffic (
   filterid smallint NOT NULL,

   ts int,
   sent bigint, recv bigint)

Das folgende Bild zeigt die Tabelle für Microsoft Access:

Die beschriebene Access-Datenbank finden Sie hier.


TrafMeter :: Paket Logging

Paket Logging (in der Lite Version nicht verfügbar)

TrafMeter kann die erfassten Daten in ein Textfile oder in eine Datenbank schreiben. Zu diesem Zweck besitzt jeder Filter ein spezielles Feature: den "Paketsammler". Der Grundgedanke der Paketsammler war die riesige Datenmenge, die beim Logging jedes einzelnen Pakets anfallen würde. Mit dem Paketsammler werden Pakete mit identischen Parametern zusammengefasst und können dann in ein Textfile oder in eine Datenbank dauerhaft gespeichert werden. Der Paketsammler stellt somit den Speicherort für die verarbeiteten Pakete dar und kann bis zu 1000 Positionen umfassen. Eine Position besteht aus folgenden IP Daten:

  • IP protocol type (1 - ICMP, 6 - TCP, 17 - UDP and etc.
    Siehe c:\winnt\system32\drivers\etc\protocols.txt or RFC 1700 for details)
  • die Ursprungs- und Ziel-IP-Adresse
  • die Ursprungs- und Ziel-MAC-Adresse
  • source and destination ports (for TCP and UDP only)
  • die Zähler für gesendete und empfangene Bytes
  • TOS (Type of Service) Feld

Der Prozess "Paketsammler leeren" erzwingt ein Schreiben der noch im Speicher befindlichen Daten in den angegebenen Speicherort (Textfile oder Datenbank). Der Paketsammler wird in einem definierbaren regelmäßigen Zeitintervall geleert (Standard: 20 Sekunden). Zu häufiges Leeren beansprucht das System unnötig. Zu seltenes Leeren kann zu einem Overflow im Paketsammler führen. Dieses Ereignis wird in den Logfiles mit dem Text "Packet Collector is full" aufgezeigt. Gelöst wird das Problem mit einer Reduzierung des Intervalls.

Die dynamischen Ports verdichten (nur für TCP und UDP)

Ein Webbrowser verwendet meist mehrere TCP Verbindungen um die Inhalte einer Webseite zu laden. Die Charakteristik dieser Pakete ist praktisch gleich, aber belasten den Paketsammler in signifikanter Weise. Da sich die Pakete nur in der Client-IP-Port unterscheiden und es sich hierbei sowieso nur um IP-Ports aus dem dynamischen Raum (1024-65535) handelt, fasst TrafMeter diese Pakete unter einer einheitlichen Client-IP-Port (65535) zusammen.

Da Client-IP-Port Angaben aus dem dynamischen Bereich der Ports unnütz sind, komprimiert/verdichtet TrafMeter diese Pakete standardmäßig, bevor diese geschrieben werden.

Wie unterscheidet TrafMeter die dynamischen Ports von den nicht-dynamischen?

Es gibt 2 Wege:

  • Wenn in einem Paket einer der Ports im Bereich 1024-65535 und der andere Port im nicht-dynamischen Bereich (1-1024) liegt.
  • Für eine neue TCP Verbindung wird das SYN flag analysiert. Die Seite, die das SYN flag setzt, ist jene Seite, die die Verbindung initialisiert. Somit ist dies auch jene Seite, die dynamische Ports verwendet.

Siehe auch:

  • Paket Logging in eine Textdatei
  • Paket Logging in eine Datenbank
  • Beispiel für die Nutzung des Paket Logging eines grossen Providers


TrafMeter :: Paket Logging in eine Textdatei

Paket Logging in eine Textdatei

Das Paket Logging in eine Datei ermöglicht die einfache Aufzeichnung eines Pakets das einer Regel in einem der Filter entspricht. Um dieses Feature zu nutzen, müssen Sie eine Formatvorlage für Dateinamen definieren. Jeder Filter muss eine eigene Vorlage besitzen, weil jeder Filter einen eigenen Paketsammler besitzt.

Ein Beispiel eines solchen Logfiles finden Sie unten. Die Zeilen die mit '---' beginnen, zeigen den Zeitpunkt als der Sammler geleert wurde. Die erste Spalte ist der Protokolltyp. Die zweite und dritte Spalte sind die Ursprungsadresse und der Ursprungsport. Die vierte und fünfte Spalte entsprechen der Zieladresse und dem Zielport. Die sechste und siebte sind der Zähler für gesendete und empfangene Bytes.

 proto    src_ip     src_port    dst_ip        dst_port     sent       recv

--- Time: 2002-11-12 11:31:14
  TCP     192.168.3.1 client    64.12.174.121     80           0         80
  TCP     192.168.3.1 client    64.236.16.136     80         160         40
  TCP     192.168.3.1 client    207.46.249.27     80          40         81
  TCP     192.168.3.1 client    64.236.16.116     80          40          0
  TCP     192.168.3.1 client   207.200.91.184     80         160         80

--- Time: 2002-11-12 11:31:32
  TCP     192.168.3.1 client    64.236.16.136     80         432        256

--- Time: 2002-11-12 11:31:50
  TCP     192.168.3.1 client  205.188.238.185    443        1573      13652
  TCP     192.168.3.1 client    64.12.174.121     80         772        330
  TCP     192.168.3.1 client    207.46.249.27     80          40         41
  TCP     192.168.3.1 client  205.188.238.185     80         733        795

Wenn die Option "Zusätzliche Felder aufzeichnen" aktiviert ist, können Sie unten aufgeführte Bild sehen. Der Wert in den runden Klammern hinter der Ursprungs- und Zieladresse entsprechen den MAC Adressen. Die letzte Spalte enthält den Dienstetyp, auch TOS - Type of Service - genannt.

--- Time: 2002-11-12 11:41:35
  TCP     192.168.3.1 (5254ab2088ad) client   12.129.206.119 (008048c28d3d)     80       11629       8154   0
  TCP     192.168.3.1 (5254ab2088ad) client     193.45.10.72 (008048c28d3d)    443          80         80   0
  TCP     192.168.3.1 (5254ab2088ad) client   216.239.39.101 (008048c28d3d)     80         567          0   0
  TCP     192.168.3.1 (5254ab2088ad) client   216.239.39.101 (008048c28d3d)     80           0       1551   16
  TCP     192.168.3.1 (5254ab2088ad) client     216.26.160.8 (008048c28d3d)    110         383        494   0
  TCP     192.168.3.1 (5254ab2088ad) client   12.129.206.119 (008048c28d3d)    110         152        166   0

--- Time: 2002-11-12 11:41:53
  TCP     192.168.3.1 (5254ab2088ad) client   216.239.39.101 (008048c28d3d)     80          80          0   0
  TCP     192.168.3.1 (5254ab2088ad) client   216.239.39.101 (008048c28d3d)     80           0         40   16
  TCP     192.168.3.1 (5254ab2088ad) client   12.129.206.119 (008048c28d3d)    110         225        412   0

Anmerkung

" client" in der dritten Spalte dynamic ports (1024-65535).


TrafMeter :: Formatvorlage für Dateinamen

Formatvorlage für Dateinamen

Die Formatvorlage für Dateinamen erlaubt die automatische Erstellung von Dateien und ermöglicht so den einfachen Wechsel von Dateien bei Wechsel des Abrechnungszeitraumes. Das Ergebnis wird aus der Vorlage und der aktuellen Systemzeit ermittelt. Ein Beispiel:

Am 1. Januar 2002 ergibt die Vorlage c:\TrafMeter\Counter_%Y-%M-%d.txt

die Datei c:\TrafMeter\Counter_2002-Jan-01.txt.

Folgende Platzhalter können in der Dateinamen Vorlage verwendet werden:

%Y | - aktuelles Jahr, 4-stellig
%y | - aktuelles Jahr, 2-stellig
%m | - aktueller Monat, 2 Zahlen
%M | - aktueller Monat, 3-stellige Abkürzung (z.B. Feb)
%d | - aktueller Tag, 2-stellig
%h | - aktuelle Stunde, 2-stellig
%n | - aktuelle Minute, 2-stellig

Anmerkung

  • Mit der Formatvorlage können auch verschachtelte Verzeichnisse angelegt werden. z.B erstellt die Vorlage c:\Reports\traffic\Enterprise\Departments\User1\%M\%d.txt das Verzeichnis c:\Reports\traffic\Enterprise\Departments\User1\Jan\


TrafMeter :: Paket Logging in eine Datenbank

Paket Logging in eine Datenbank

Paket Logging in eine Datenbank erlaubt die leistungsfähigere Speicherung und Analyse von Paketen die einer Regel in einem Filter entsprechen. Um diese Fähigkeit zu nutzen, wird folgendes vorausgesetzt:

  • Datenbank Verbinungsstring (OLE DB Connection String)
  • Bezeichnung der Datenbanktabelle für das Paket Logging
  • Die Methode wie IP Adressen gespeichert werden (als Textzeichen, als vorzeichenloser INT Wert oder als INT Wert mit Vorzeichen)

Anmerkung

  • Die Tabellen müssen manuell erstellt werden, bevor TrafMeter die Daten speichern kann.

Die Methode wie die IP Adressen gespeichert werden

  • Als Text. Die Felder src_ip (Ursprungsadresse) und dst_ip (Zieladresse) muss als 16 Byte langes Textfeld angelegt werden. Platzbedarf: 128 Bit.
  • Als vorzeichenloser INT Datentyp. Vor dem Speichern werden die Ursprungs- und Zieladresse in vorzeichenlose INT Werte umgewandelt. Bsp: die IP Adresse 192.168.4.2 wird somit als 3232236546 dargestellt. Platzbedarf: 32 Bit
  • INT Datentyp mit Vorzeichen. Vor dem Speichern werden die Ursprungs- und Zieladresse in INT Werte mit Vorzeichen umgewandelt und die Ursprungs- und Zielports in 16 Bit Werte mit Vorzeichen.

Anmerkung

  • Microsoft SQL Server kennt keinen vorzeichenlosen INT Datentyp. Verwenden Sie stattdessen den "bigint" Datentyp.

Siehe auch:

  • Tabellenfelder die für die Aufzeichnung des Pakete nötig sind
  • nützliche SQL Skripte für die Analyse der aufgezeichneten Pakete


TrafMeter :: Datenbanktabelle für das Paket Logging

Datenbanktabelle für das Paket Logging

Die Tabelle muss manuell erstellt werden bevor TrafMeter IP Pakete aufzeichnen kann. Die Mindestanzahl der Felder ist:

N | Feld Namen | Feld Typ | Beschreibung
1. | filterid | smallint | Filter ID (von 1 bis N. N ist die Nummer des Filters im Filtersatz)
2. | proto | smallint | IP Protokoll Typ (1 - ICMP, 6 - TCP, 17 - UDP, usw. Siehe "protocols.txt" für Details)
3. | src_ip | char(16) | IP-Ursprungsadresse (in dezimal-gepunkteter Schreibweise, z.B. 192.168.3.250)
4. | src_port | int | Ursprungsport (nur für TCP oder UDP, der Bereich ist 0 - 65535)
5. | dst_ip | char(16) | IP-Zieladresse
6. | dst_port | int | Zielport (nur für TCP oder UDP)
7. | sent | int | Zähler für gesendete Bytes
8. | recv | int | Zähler für empfangene Bytes

Wenn zusätzlich dass Logging der MAC Adresse, des TOS (Type of Service) Feldes oder des Feldnamens aktiviert ist, müssen zusätzliche Tabellenfelder definiert werden:

N | Feld Namen | Feld Typ | Beschreibung
9. | src_mac | char(16) | Ursprungs MAC Adresse (e.g. 1a2c3e4d556f)
10. | dst_mac | char(16) | Ziel MAC Adresse
11. | tos | smallint | TOS (Type of Service) Feld (der Bereich ist 0-255)
12. | filtername | char(30) | Der Filtername (Die Länge des Feldes muss gleich oder grösser der Länge des längsten Feldnamens sein)

Siehe auch:

  • Microsoft SQL Server Syntax um die Tabellen für das Paket Logging zu erstellen
  • MySQL Syntax um die Tabellen für das Paket Logging zu erstellen
  • Microsoft Access Syntax um die Tabellen für das Paket Logging zu erstellen


TrafMeter :: Microsoft SQL Server Syntax um die Tabellen für das Paket Logging zu erstellen

Microsoft SQL Server Syntax um die Tabellen für das Paket Logging zu erstellen

Erstellung der Tabelle für das Paket Logging mit den minimal benötigten Feldern:

CREATE TABLE [dbo].[packets] (
   ts datetime DEFAULT CURRENT_TIMESTAMP NOT NULL,
   filterid smallint NOT NULL,
   proto smallint,
   src_ip char(16),
   src_port int,
   dst_ip char(16),
   dst_port int,
   sent int, recv int)

Erstellung der Tabelle für das Paket Logging mit zusätzlichen Feldern:

CREATE TABLE [dbo].[packets] (
   ts datetime DEFAULT CURRENT_TIMESTAMP NOT NULL,
   filterid smallint NOT NULL,
   filtername char(30),
   proto smallint,
   tos smallint,
   src_mac char(16),
   src_ip char(16),
   src_port int,
   dst_mac char(16),
   dst_ip char(16),
   dst_port int,
   sent int, recv int)

Anmerkung

Microsoft SQL Server kann beim Einfügen eines neuen Datensatzes das aktuelle Datum und die aktuelle Zeit selbst einfügen. Ist dies gewünscht, verwenden Sie die CURRENT_TIMESTAMP Funktion.


TrafMeter :: MySQL Server Syntax um die Tabellen für das Paket Logging zu erstellen

MySQL Syntax um die Tabellen für das Paket Logging zu erstellen

Erstellung der Tabelle für das Paket Logging mit den minimal benötigten Feldern:

create table packets (
   ts timestamp,
   filterid smallint  NOT NULL,
   proto tinyint,
   src_ip char(16),
   src_port smallint unsigned,
   dst_ip char(16),
   dst_port smallint unsigned,
   sent int unsigned, recv int unsigned);

Erstellung der Tabelle für das Paket Logging mit zusätzlichen Feldern:

create table packets (
   ts timestamp,
   filterid smallint NOT NULL,
   filtername char(30),
   proto tinyint,
   tos tinyint,
   src_ip char(16),
   src_mac char(16),
   src_port smallint unsigned,
   dst_ip char(16),
   dst_mac char(16),
   dst_port smallint unsigned,
   sent int unsigned, recv int unsigned);

Note

MySQL kann beim Einfügen eines neuen Datensatzes das aktuelle Datum und die aktuelle Zeit selbst einfügen. Ist dies gewünscht, verwenden Sie den "timestamp" type.


TrafMeter :: Paket Logging :: Microsoft Access Syntax um die Tabellen für das Paket Logging zu erstellen

Microsoft Access Syntax um die Tabellen für das Paket Logging zu erstellen

Erstellung der Tabelle für das Paket Logging mit den minimal benötigten Feldern:

Erstellung der Tabelle für das Paket Logging mit zusätzlichen Feldern:

Die beschriebene Access-Datenbank finden Sie hier.

Anmerkung

Microsoft Access kann beim Einfügen eines neuen Datensatzes das aktuelle Datum und die aktuelle Zeit selbst einfügen. Ist dies gewünscht, verwenden Sie die Jetzt() Funkton als Default Wert.


TrafMeter :: Nützliche SQL Skripte für die Analyse der aufgezeichneten Pakete

Nützliche SQL Skripte für die Analyse der aufgezeichneten Pakete

TrafMeter enthält kein Tool für die Erstellung von SQL Analysen aus einer Paket Logging Datenbank. Für die beigefügten Beispiele haben wie die im Lieferumfang des Microsoft SQL Servers enthaltenen Tools benutzt.

1. Den gesamten verursachten Traffic pro Filter ermitteln

select filterid, sum(sent),sum(recv) from packets group by filterid

2. Den gesamten verursachten Traffic pro Filter pro Tag ermitteln

select filterid as filterid, sum(sent) as sent, sum(recv) as recv from packets
   where datediff(day,'2002-11-24',ts)=0
   group by filterid
   order by filterid

3. Den gesamten verursachten Traffic pro Filter für einen bestimmten Monat ermitteln

select filterid as filterid, sum(sent) as sent, sum(recv) as recv from packets
   where datediff(month,'2002-11-01',ts)=0
   group by filterid
   order by filterid

4. Den gesamten verursachten Traffic eines Filters für einen bestimmten Tag in einem bestimmten Monat ermitteln

Setzen Sie die Variable @dd auf den ersten Tag des entsprechenden Monats.

declare @dd datetime
set @dd='2002-11-01'
select datediff(day,@dd,ts) as mday, sum(sent) as sent, sum(recv) as recv
   from packets
   where (filterid=1 AND (datediff(month,@dd,ts)=0))
   group by datediff(day,@dd,ts)
   order by datediff(day,@dd,ts)

Das obige Beispiel zeigt die Datum anhand einer auf 0 basierenden Indexes. D.h. der erste Tag im Monat ist 0, der zweite Tag ist 1, etc. Um dies zu vermeiden, kann folgendes Skript mit einer temporären Tabelle verwendet werden:

drop table #p1
go
declare @dd datetime
set @dd='2002-11-01'
select datediff(day,@dd,ts) as mday, sum(sent) as sent, sum(recv) as recv
   into #p1
   from packets
   where (filterid=1 AND (datediff(month,@dd,ts)=0))
   group by datediff(day,@dd,ts)
go
update #p1 set mday=mday+1
go
select * from #p1 order by mday

5. Den gesamten verursachten Traffic eines bestimmten Hosts eines bestimmten Filter in einem bestimmten Monat ermitteln

select dst_ip, sum(sent) as sent, sum(recv) as recv
   from packets
   where (filterid=1 AND (datediff(month,'2002-11-01',ts)=0))
   group by dst_ip


TrafMeter :: Host Header Logging

Host Header Logging (in der Lite Version nicht verfügbar)

Dies erlaubt die Aufzeichnung der HTTP Hostnamen in eine Textdatei oder in eine Datenbank inklusive der übertragenen Bytes. Was ist der Unterschied zwischen dem Logging von Host Header Daten durch TrafMeter und der Analyse der Logfiles eines Proxy Servers? Die Antwort finden Sie in der beigefügten Tabelle.

 | Analyse der Proxy Logfiles | TrafMeter Host Header Logging
Wird ein Proxy Server benötigt? | Ja. | Nein. Das ist ein Vorteil, wenn in bestimmten Fällen kein Proxy Server installiert werden kann.
Wird der mitübertragene HTTP Overhead aufgezeichnet? | Nein. | Mitaufgezeichnet werden: - Header der HTTP Antwort - IP und TCP Header - wiederholt übertragene TCP Segmente die ohne Bestätigung geblieben sind.
Welche Datenmenge wird bei aktivierter GZIP Komprimierung aufgezeichnet (bei "on the fly" komprimierten Webseiten)? | Die Grösse der Datei auf der Platte. | Die effektiv über die Internetverbindung übertragene Menge (kann bei aktivierter GZIP Komprimierung um den Faktor 2-4 geringer als die eigentliche Dateigrösse sein)

Um diese Option zu nutzen, müssen Sie das "Host Header Logging" im Filter Editor aktivieren und die Parameter setzen.

Welche HTTP Request Typen werden analysiert?

  1. HTTP/1.1 (RFC 2068). Ein HTTP/1.1 Request besteht aus dem Feld "Host" welches den Hostnamen enthält. Somit ist es möglich, unterschiedliche Webseiten anzusprechen, die auf der selben IP Adresse und dem selben Port liegen. Beispiel für einen HTTP/1.1 Request:
    GET / HTTP/1.1
Host: www.w3.org
  2. HTTP/1.0 (RFC 1945). In HTTP/1.0 gibt es kein "Host" Feld, deshalb wird die IP Adresse (in gepunkteter Dezimalschreibweise) anstatt dem Hostnamen aufgezeichnet. Beispiel für einen HTTP/1.0 Request:
    GET / HTTP/1.0
  3. HTTP Request über einen Proxy Server. In diesem Fall steht der Hostnamen in der HTTP Request Zeile. Beispiel für einen HTTP Request über einen Proxy server:
    GET http://www.w3.org/ HTTP/1.0
  4. FTP Request über einen Proxy server. Gleich wie oben aber mit einem anderen Protokoll. Beispiel:
    GET ftp://ftp.w3.org/ HTTP/1.0

What types of HTTP requests are not analyzed?

It is not possible to analyze HTTPS (or secure HTTP) because this protocol uses an encryption.

See also:

  • Host Header Logging into plaintext file
  • Host Header Logging into database


TrafMeter :: Host Header Logging in Textfile

Host Header Logging in ein Textfile

Dies ist die einfachste Möglichkeit um HTTP Request aufzuzeichnen. Um diese Aufzeichnungsart zu ermöglichen, müssen Sie eine Dateinamenvorlage für die Logfiles definieren. Jeder Filter muss eine eigene Vorlage benutzen, da jeder Filter einen unabhängigen Zähler besitzt.

Jede Zeile entspricht einem HTTP Request. Ein Beispiel:

2003-11-26 18:39:13   4 11 1  GET www.w3.org 192.168.4.5:1410 216.16.16.105:80 1218 24609
2003-11-26 18:39:19   4 11 1  GET www.w3.org 192.168.4.5:1411 216.16.16.105:80 748 12006
2003-11-26 18:39:31   4 11 1  GET www.w3.org 192.168.4.5:1412 216.16.16.105:80 718 12060

zur Erklärung:

Spalte | Beschreibung
1 | Datum wann der Datensatz geschrieben wurde
2 | Zeit zu der der Datensatz geschrieben wurde
3 | Filter Id
4 | HTTP Request Typ
5 | Exit Code des HTTP Request
6 | HTTP Request Methode
7 | Hostname
8 | IP Adresse und TCP Port des Clients
9 | IP Adresse und TCP Port des Servers
10 | Anzahl der Bytes die vom Client an den Server übertragen wurden
11 | Anzahl der Bytes die vom Server zum Client übertragen wurden


TrafMeter :: Host Header Logging in eine Datenbank

Host Header Logging in eine Datenbank

Host Header Logging in eine Datenbank ist eine äußerst effektive Methode um HTTP Anfragen aufzuzeichnen und zu analysieren. Um dieses Feature nutzen zu können, benötigen Sie:

  • Datenbank Connection String
  • Den Namen der Datenbanktabelle für das Host Header Logging

Anmerkung

  • Die Datenbanktabelle muss manuell erstellt werden, before TrafMeter die Datensätze aufzeichnen kann.

Siehe auch:

  • Tabellenfelder die für die Aufzeichnung nötig sind


TrafMeter :: Datenbanktabelle für das Host Header Logging

Datenbanktabelle für das Host Header Logging

Die Tabelle muss manuell erstellt werden bevor TrafMeter die Hosts aufzeichnen kann. Die benötigten Felder sind:

N | Name | Typ | Beschreibung
1. | rtime | datetime | Zeit an der der HTTP request abgeschlossen wurde
2. | filterid | smallint | Filter ID
3. | rtype | smallint | HTTP Request Typ
4. | method | smallint | HTTP Request Methode
5. | reason | smallint | Exit Code des HTTP Request
6. | clt_ip | char(16) | IP Adresse des Client (in gepunkteter Dezimalschreibweise, z.B. 192.168.3.250)
7. | clt_port | int | TCP Port des Client (im Bereich 0-65535)
8. | srv_ip | char(16) | IP Adresse des Servers (in gepunkteter Dezimalschreibweise, z.B. 192.168.3.1)
9. | srv_port | int | TCP Port des Servers (im Bereich 0-65535)
10. | clt_bytes | int | Anzahl der Bytes die vom Client zum Server übertragen wurden
11. | srv_bytes | int | Anzahl der Bytes die vom Server zum Client übertragen wurden
12. | host | char(250) | Hostname

Siehe auch:

  • Microsoft SQL Server Syntax um die Tabelle für das Host Header
    Logging zu erstellen
  • MySQL Syntax um die Tabelle für das Host Header Logging zu erstellen
  • Microsoft Access Syntax um die Tabelle für das Host Header Logging zu erstellen


TrafMeter :: Microsoft SQL Server Syntax Host Header Logging Tabelle

Microsoft SQL Server Syntax um die Tabelle für das Host Header Logging zu erstellen

Um die Tabelle mit der Mindestanzahl der Felder zu erstellen:

CREATE TABLE [dbo].[hosts] (
   ts datetime DEFAULT CURRENT_TIMESTAMP NOT NULL,
   rtime datetime,
   filterid smallint NOT NULL,
   rtype smallint,
   method smallint,
   reason smallint,
   clt_ip char(16),
   clt_port int,
   srv_ip char(16),
   srv_port int,
   clt_bytes bigint,
   srv_bytes bigint,
   host char(250))

Anmerkung

  • Feld "ts" enthält das Datum/die Zeit wann der Datensatz erstellt wurde. Microsoft SQL Server muss dieses Feld selbst ausfüllen. Um dies zu erreichen, definieren Sie die CURRENT_TIMESTAMP Funktion als Defaultwert für das Feld.


TrafMeter :: MySQL Server Syntax Host Header Logging Tabelle

MySQL Syntax um die Tabelle für das Host Header Logging zu erstellen

Um die Tabelle mit der Mindestanzahl der Felder zu erstellen:

create table hosts (
   ts timestamp,
   rtime datetime,
   filterid smallint  NOT NULL,
   rtype smallint,
   method smallint,
   reason smallint,
   clt_ip char(16),
   clt_port smallint unsigned,
   srv_ip char(16),
   srv_port smallint unsigned,
   clt_bytes int unsigned,
   srv_bytes int unsigned,
   host char(250));

Note

  • Feld "ts" enthält das Datum/die Zeit wann der Datensatz erstellt wurde. MySQL muss dieses Feld selbst ausfüllen. Um dies zu erreichen, definieren Sie das Feld mit dem Datentyp "timestamp".


TrafMeter :: Microsoft Access Syntax Host Header Logging Tabelle

Microsoft Access Syntax um die Tabelle für das Host Header Logging zu erstellen

Um die Tabelle mit der Mindestanzahl der Felder zu erstellen

Die beschriebene Access-Datenbank finden Sie hier.

Note

  • Das Feld "ts" zeigt auf die Zeit, wann der Datensatz angelegt wurde. Microsoft Access muss diesen Wert selbst einfügen. Dies kann mit der Funktion Jetzt() als Defaultwert für das Feld "ts" erreicht werden.


TrafMeter :: Ergebnis Codes für das Host Header Logging

Ergebnis Codes für das Host Header Logging

Typ des HTTP Request

Code | Beschreibung
10 | HTTP/1.0
11 | HTTP/1.1
20 | HTTP Request über einen Proxy server
20 | FTP Request über einen Proxy server

HTTP Request Methoden

Code | Beschreibung
1 | GET
2 | POST
3 | HEAD
4 | OPTIONS
5 | PUT
6 | DELETE
7 | TRACE

HTTP Request Exit Code

Code | Beschreibung
1 | TCP Verbindung endete mit dem Austausch der FIN Pakete
2 | TCP Verbindung endete mit dem Austausch der RST Pakete
3 | Gemäß der HTTP/1.1 Spezifikation ist es möglich, mehrere HTTP Anfragen durch eine einzelnde TCP Verbindung zu senden (auch "HTTP Keep-Alive Requests" genannt). Dieser Exit Code bedeutet, dass das erste Paket des nächsten HTTP Request von einem Client gesendet wird, der die selbe TCP Verbindung benutzt.
4 | Timeout der TCP Verbindung (Standard: 600 Sekunden)
5 | Die Verarbeitung des Traffics wurde gestoppt und der unvollständige HTTP Request wurde geloggt ohne dass auf das letzte Paket der TCP Verbindung gewartet wurde.


TrafMeter :: VPN

Verarbeiten von VPN Paketen

Es gibt 2 Arten, um VPN Pakete in TrafMeter zu verarbeiten:

 | Verarbeitung auf einer NDISWAN Schnittstelle | Verarbeitung auf einer Ethernet Schnittstelle
Verarbeitung im promiskuitiven Modus | Nein (nur Pakete mit der Ursprungs- oder Zieladresse des lokalen PC möglich) | Ja (jeder Ursprung und jedes Ziel möglich)
Counting encrypted VPN packets | Ja | Nein
Typ des VPN Pakets | Jeder | nur Jene, die GRE (Nummer 47) als Transportprotokoll benutzen

Verarbeitung auf einer NDISWAN Schnittstelle

Der einfachste Weg um VPN Pakete zu erfassen. Einfach die RAS (NDISWANIP) Schnittstelle auswählen und TrafMeter kann die entschlüsselten IP Pakete der VPN Verbindung verarbeiten.

Verarbeitung auf einer Ethernet Schnittstelle

TrafMeter kann erfasste Pakete analysieren und die darin enthalten Daten wie ganz normale IP Pakete verarbeiten. TrafMeter verarbeitet hierbei VPN Pakete, die GRE (Nummer 47) als Transportprotokoll nutzen. PPP Pakete (Nummer 0x880B) und die IP Pakete mit allen nötigen Informationen sollten in diesen GRE Paketen enthalten sein. VPN Pakete können nach MPPC (RFC 2118) komprimiert sein, dürfen aber nicht verschlüsselt sein.

Es sollten alle Ethernet Schnittstellen ausgewählt sein, die für VPN Verbindungen genutzt werden. In diesem Fall entfernt TrafMeter alle unnötigen Informationen um die eingebetteten IP Pakete zu erhalten.

Standardmäßig ist die Analyse von VPN Paketen nicht aktiviert, kann aber in einem speziellen Filter durch die Auswahl der entsprechenden Option im Reiter "Diverses" aktiviert werden.

Regeln für VPN Pakete entsprechen exakt den Regeln für normale IP Pakete weil TrafMeter das IP Paket aus dem VPN Paket extrahiert.

Ist meine VPN Verbindung verschlüsselt?

Öffnen Sie das Statusfenster ihrer VPN Verbindung:

Statusfenster ohne Verschlüsselung | Statusfenster mit Verschlüsselung


TrafMeter :: Registry Einstellungen

Registry Einstellungen für den TrafMeter Dienst

Alle Einstellungen für den TrafMeter Dienst (mit Ausnahme der Filter) werden in folgendem Registrierungspfad gespeichert:

[HKLM\Software\TrafMeter Software\TrafAgent\Settings]

Es gibt einige Einstellungen des TrafMeter Dienstes, die nur durch die händische Modifikation der Registry vorgenommen werden können:

  • DeniedPktLogLevel (Typ REG_DWORD). Definiert die Art des Loggings der verweigerten Pakete:
    0 - kein Logging der verweigerten Pakete.
    1 - Logging der verweigerten Pakete aktivieren.
    2 - gleich wie Punkt 1 aber inklusive Aufzeichung der MAC Adresse
  • TrafficLimitMBytes (Typ REG_DWORD). Hiermit kann die Megabytegrenze für die Überprüfung in einer Regel definiert werden. Wichtig bei der Definition von Trafficlimitierungen (Beispiel: 1000000 definiert 1 MB als 1000000 Bytes). Standardmäßig wird 1 MB mit 1048576 Bytes definiert.
  • LogMemUsage (Typ REG_SZ). Definiert einen voll Pfad eines Logfiles für die Überwachung des Speicherverbrauchs des TrafMeter Dienstes. Nützlich, um eventuelle Speicherprobleme des Dienstes ausfindig zu machen. Standardmäßig ist dieses Logging deaktiviert.
  • MSSQLConvertDateTime (Typ REG_DWORD) - Dies ermöglicht die Benutzung der Funktion CONVERT() für die Konvertierung des Typs 'datetime' während der Aufzeichnung von Hostheader in eine MS SQL Datenbank:
    0 - Funktion CONVERT() deaktiviert (Default)
    1 - Funktion CONVERT() aktiviert. Verwenden Sie diese Option, wenn das Format nicht 'yyyy-mm-dd hh:mi:ss' lautet.
  • BindAddr (Typ REG_SZ). Definiert die IP Adressen (in gepunkteter Dezimalschreibweise) die für eingehende Verbindungen von der Trafmeter Administrations Konsole akzeptiert werden. Diese Adresse muss dem PC mit dem TrafMeter Dienst entsprechen.


TrafMeter :: FAQ

F: Was ist der Unterschied zwischen den einzelnen TrafMeter Versionen?

A: siehe Tabelle.

F: Ist es möglich die Lite und die Vollversion gleichzeitig laufen zu lassen?

A: Nein. Es kann immer nur ein TrafMeter Dienst auf einem Rechner laufen. Sie können aber mehrere Administrationskonsolen für die Verwaltung mehrerer Dienste von Ihrem PC aus starten.

F: Ich bekomme die Meldung "Speicher für neuen Filter kann nicht reserviert werden". Was bedeutet dies?

A: Dies bedeutet, dass Sie die TrafMeter Freeware Edition benutzen und die maximale Anzahl der in der Freeware Version möglichen Filter erreicht haben. Um diese Beschränkung zu umgehen, müssen sie eine Lizenz erwerben.

F: Müssen unterschiedliche Version der Administrationskonsole für die Verwaltung unterschiedlicher Diensteversionen benutzt werden?

A: Nein. Die Konsole unterstützt alle Versionen der TrafMeter Dienste.

F: Wie kann ich den TrafMeter Dienst über die Eingabeaufforderung neu starten?

A: Der TrafMeter Dienst kann folgendermaßen gestartet bzw. gestoppt werden:

  • net stop trafsvc stoppt den Dienst
  • net start trafsvc startet den Dienst

F: Ich habe das Passwort für den TrafMeter Dienst vergessen. Was soll ich tun?

A: Entfernen Sie in der Registry den Schlüssel [HKLM\Software\TrafMeter Software\TrafAgent\Settings\Password] und starten Sie den Dienst neu. Das Passwort wird damit gelöscht sein.

F: Ich habe eine falsche IP Adresse für eingehende Verbindungen im Dienst definiert (Dialogbox "Optionen", Tab "Administration"). Jetzt kann ich mit der Administrationskonsole keine Verbindung mehr aufbauen (bekomme"Error code = 10057"). Was soll ich tun?

A: Das ist ein Sicherheitsfeature von TrafMeter und sollte wirklich nur verwendet werden, wenn man genau weiss was man macht. Um diese zurück zu setzen, entfernen Sie den Registrierungsschlüssel [HKLM\Software\TrafMeter Software\TrafAgent\Settings\BindAddr] und Starten Sie den Dienst neu. Anschließend sollten Sie sich mit dem Dienst wieder verbinden können.

F: Ist die Administration über das Netzwerk sicher? Kann man via Sniffing das Passwort des Dienstes herausfinden?

A: Remote Administration ist absolut sicher. TrafMeter benutzt nur kurzfristig gültige Passwörter für die Administration. Das Sniffing ist somit nutzlos.

F: Welche Firewall empfehlen Sie bei der Benutzung von TrafMeter?

A: Benutzen Sie die Firewall im Service Pack 2 von Microsoft Windows XP.

F: Nach der Installation von TrafMeter 4.x auf einem PC mit ZoneAlarm 4.x habe ich festgestellt, dass die gesamte Netzwerkaktivität von einer der Netzwerkkarten blockiert wird. Was läuft hier falsch?

A: Leider benutzt ZoneAlarm unsichere NDIS Hooks die mit dem in TrafMeter verwendeten Treiber kolledieren. Deshalb kann dieses Problem nicht von uns gelöst werden.

F: TrafMeter findet meine Netzwerkkarten nicht. Was soll ich tun?

A: Erstens: Starten Sie Ihren PC neu. Dies löst im Großteil der Fälle das Problem. Wenn nicht, senden Sie uns die Datei "support.txt" aus dem TrafMeter Startverzeichnis (normalerweise C:\Programme\TrafMeter\support.txt").

F: Ich habe das HTTP Host Header Logging aktiviert und zeichne in eine Microsoft Access Datenbank auf. Zuerst hat alles funktioniert und auf einmal tauchten Fehler auf. Wieso?

A: Eventuell haben Sie eine Limitierung der Microsoft Access Datenbank überschritten. Siehe auch http://support.microsoft.com/default.aspx?scid=kb;en-us;302524&Product=acc2003


TrafMeter :: FAQ Traffic

Traffic counting with TrafMeter FAQ

F: Ich habe TrafMeter auf einem NAT router installiert, um den Internettraffic der Arbeitsstationen im lokalen Netzwerk zu messen. Dazu habe ich für jede Arbeitsstation einen Filter mit der Regel "Eine spezifische IP Adresse <-> IP Adressen des WAN" mit dem Flag "Beide Richtungen" erstellt. LAT wurde korrekt erstellt und die Netzwerkadapter ausgewählt. Nach dem Starten der Verarbeitung werden aber nur eingehende Bytes gezählt, nicht aber die Ausgehenden. Wie kann das Problem umgangen werden?

A: Verwenden Sie den aktiven Verarbeitungsmodus um Traffic auf NAT Routern zu erfassen.

F: Wie erfasst TrafMeter die Länge der IP Pakete?

A: Jedes IP Paket besitzt ein Feld "Total Length" im Header. Dieses Feld enthält die Gesamtanzahl an Bytes im Paket, inklusive der Länge des Headers. TrafMeter benutzt diesen Wert um die Länge des IP Paketes zu ermitteln.

F: Ich habe einen Filter mit einer Regel erstellt, die Traffic von "Allen IP Adressen" zu "Allen IP Adressen" aufzeichnen soll. Die "gespiegelt" Option ist aktiviert. Die Anzahl der gesendeten Bytes entspricht der Anzahl der verarbeiteten Bytes. Nur die Anzahl der empfangenen Bytes ist '0'. D.h. eingehender Traffic wird nicht gezählt. Warum?

A: Datenverkehr kann nicht in gesendete und empfangene Richtung gesplittet werden, wenn die Option von jeder zu jeder IP Adresse verwendet wird und die "gespiegelt" Option aktiviert ist. Zur Erklärung: Stellen Sie sich vor, Sie stehen gleichzeitig auf beiden Seiten einer Strasse und zählen die Autos die von beiden Seiten kommen. Welches sind nun die Autos die von rechts und welche sind jene Autos die von links kommen? Dies ist nicht beantwortbar, solange Sie keinen Referenzpunkt für die Richtung haben.

F: Ich habe einen Filter mit "Mein Computer" zu "Jeder Adresse" erstellt, der ausschließlich ICMP Pakete erfasst. Wenn ich einen PC im Netzwerk anpinge, arbeitet der Zähler ganz normal. Wenn ich aber einen nicht existierenden PC anpinge, werden die Zähler nicht aktualisiert. Was läuft hier falsch?

A: Wenn Sie einen PC im Netzwerk anpingen, so wird eine ARP-Anforderung gesendet um die MAC-Adresse der angepingten IP-Adresse zu ermitteln. Wenn Ihr Computer keine ARP-Antwort auf die Anforderung erhält (weil die Zieladresse nicht existiert) wird ihr Computer auch kein ICMP Paket verschicken. Deshalb werden auch die Zähler nicht erhöht.

F: Meine Internetverbindung läuft über einen an einen Ethernet Hub angeschlossenen DSL Router. Mein PC hat die IP Adresse 192.168.1.2 und mein DSL Router die IP Addresse 192.168.1.1. Nun möchte ich den Datenverkehr zwischen meinem PC und dem Internet messen. Dazu habe ich einen Filter mit einer Regel erstellt die 192.168.1.2 als Ursprungsadresse und 192.168.1.1 als Zieladresse enthält. Nach dem Starten der Verarbeitung bleiben aber alle Zähler auf 0. Was mache ich falsch?

A: Der von Ihnen definierte Filter verarbeitet ausschließlich Pakete, die an den Router gerichtet sind. Pakete ins oder vom Internet haben als Zieladresse aber nicht die Adresse des Routers. Die von Ihnen gewünschte Verarbeitung erreichen Sie am besten dadurch, in dem Sie die LAT mit den IP-Adressen ihres lokalen Netzwerkes definieren. Anschließend verwenden Sie in der Filterregel anstatt der IP des Routers den Ausdruck "IP Adressen des WAN".

F: Ich benutze TrafMeter auf meinm Internetgateway auf dem auch der Proxy Server SquidNT läuft. Alle Arbeitsstationen im lokalen Netzwerk benutzen den Proxy. TrafMeter zeichnet jetzt einwandfrei den Traffic zwischen den Clients und dem Proxy auf. Ich möchte nun aber den Traffic, der aus dem Cache kommt, nicht aufzeichnen. Wie wird das gemacht?

A: Das ist nicht möglich. TrafMeter verarbeitet Netzwerkpakete und diese Pakete enthalten keine Informationen, ob diese aus dem Internet kommen oder aus dem Cache des Proxy.

F: Wie kann man FTP Datenverkehr messen?

A: FTP ist eine Abkürzung für "File Transfer Protocol" (www.deerfield.com). FTP wird für die Übertragung von Dateien über das Internet benutzt. Es gibt 2 Typen von FTP Verbindungen: "aktive" und "passive". Die Regeln, die Sie definieren müssen um FTP Datenverkehr aufzuzeichnen, sind abhängig vom verwendeten FTP Typ. Standardmäßig wird von den meisten Browsern "Passives FTP" benutzt, während bei vielen speziellen FTP Client Applikationen (z.B. CuteFTP, Internet Neighborhood, WS-FTP) das "Aktive FTP" benutzt wird.

Unabhängig vom verwendeten Typ besteht jede FTP Übertragung aus 2 unabhängigen Verbindungen zwischen dem Client und dem FTP Server. Eine dieser Verbindungen wird als "Control" Verbindung bezeichnet. Diese Verbindung übernimmt das Verbinden und das Login zum FTP Server. Sobald der User eingeloggt ist, wird die "Data" Verbindung erstellt, welche die Verzeichnisinhalte überträgt und über die die Dateien herunter- und hochgeladen werden.

Die "Control" Verbindung unterscheidet sich bei Passiv und Aktiv FTP nicht. Der Client baut eine TCP Verbindung vom temporären Bereich seiner TCP-Ports zum Server-Port 21 auf und sagt "Hallo! Ich möchte eine Verbindung mit Dir aufbauen. Hier ist meine Name und mein Passwort". Was anschließend passiert, hängt davon ab ob Aktiv oder Passiv FTP verwendet wird.

Information: Als temporärer Port-Bereich wird jener Bereich von Ports bezeichnet, der oberhalb von 1023 liegt.

Im Aktiv FTP Modus übermittelt der Client schon beim "Hallo" dem Server einen weiteren Port aus dem temporären Bereich. Der Server versucht bei korrekten Logindaten, eine "Data" Verbindung mit diesem Port aufzubauen. Auf Serverseite wird dazu der TCP Port 20 verwendet.

Im Passiv Modus übermittelt der Server nach erfolgreichem Login dem Client einen Port aus dem temporären Bereich, den der Client dazu benutzen muss, um selbst die "Data" Connection aufzubauen. Für die "Data" Connection verwendet der Client ebenfalls einen Port aus dem temporären Bereich.

Der Hauptunterschied liegt also darin, von welcher Seite die "Data" Verbindung aufgebaut wird. Beim aktiven FTP wird die "Data" Verbindung von einem fixen Port aus aufgebaut. Im passiven Modus ist stets der Client der Ausgangspunkt der Verbindungen.

Beispiel für "Aktives FTP":
[1] "Control" Verbindung: Client Port 1026 -> Server Port 21
[2] "Data" Verbindung: Server Port 20 -> Client Port 1027

Beispiel für "Passives FTP":
[1] "Control" Verbindung: Client Port 1026 -> Server Port 21
[2] "Data" Verbindung: Client Port 1027 -> Server Port 2065

Wir hoffen, dies reicht aus um die richtigen Regeln zu kreieren, um FTP Traffic aufzuzeichnen.


TrafMeter :: Beispiel 1

Beispiel 1

Ziel:
Den ein- und ausgehenden Traffic meines Computers ermitteln.

Vorgehensweise:
Es muss ein Filter mit einer einzigen Regel erstellt werden.

Filter 1. Traffic von und zu meinem Computer.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | Mein Computer |  | Jede IP Adresse |  | Ja | Zählen |

Anmerkung

  • Dies ist der einfachste Filter um eine Verarbeitung starten zu können
  • Wenn Sie "Mein Computer" sowohl als Ursprungs- wie auch als Zieladresse verwenden, erscheint eine Fehlermeldung
  • Ein Fehler erscheint auch, wenn Sie "Jede IP Adresse" als Ursprung und "Mein Computer" als Ziel verwenden.


TrafMeter :: Beispiel 2

Beispiel 2

Ziel
Den ein- und ausgehenden Traffic des eigenen PC und zum PC mit der IP 192.168.2.2 erfassen.

Vorgehensweise
Zwei Filter sind nötig. Der erste Filter erfasst den Traffic zum PC mit der IP 192.168.2.2. Der zweite Filter zeichnet den gesamten Traffic mit Ausnahme des Traffics zur IP 192.168.2.2 auf.

Filter 1. Traffic von meinem Computer zu 192.168.2.2.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | Mein Computer |  | 192.168.2.2 |  | Ja | Zählen & Durchlassen |
Filter 2. Gesamter Traffic meines Computers mit Ausnahme 192.168.2.2.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
2 | Jedes | Mein Computer |  | Jede |  | Ja | Zählen |

Der Ablauf kann folgendermaßen erklärt werden: Erfasste Pakete die dem ersten Filter entsprechen werden gezählt und vom zweiten Filter nicht erfasst, da eine Aktion mit "Durchlassen" gewählt wurde. Somit gelangen nur jene Pakete zum zweiten Filter, die dem ersten Filter nicht entsprechen.


TrafMeter :: Beispiel 3

Beispiel 3

Ziel
WWW Traffic einer spezifischen IP Adresse (z.B., 192.168.0.1) zu jedem Host erfassen.

Vorgehensweise
Es muss ein Filter mit 2 Regeln erstellt werden. Die erste Regel erfasst den "normalen" (unverschlüsselten) Traffic. Die zweite Regel erfasst den verschlüsselten Traffic.

Filter 1. WWW Traffic von Host 192.168.0.1 zu jedem Host
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | TCP | 192.168.0.1 | Jeder | Jede | 80 | Ja | Zählen |
2 | TCP | 192.168.0.1 | Jeder | Jede | 443 | Ja | Zählen |

Anmerkung

  • Um das Beispiel zu vereinfachen, nehmen wir an, dass der WWW Traffic über die Standardports TCP 80 und 443 läuft. Zu beachten ist, dass ein Webserver auf allen erdenklichen Ports (z.B. 8080) auf eingehende WWW-Verbindungen warten kann.


TrafMeter :: Beispiel 4

Beispiel 4

Ziel
Sie sind Administrator des firmeninternen Lotus Notes Servers (z.B. mit der IP Adresse 216.106.88.42). Der Server akzeptiert eingehende Lotus Notes- und SMTP-Verbindungen und erzeugt selbst ausgehende Lotus Notes- und SMTP-Verbindungen. Sie wollen nun sowohl den Lotus Notes- als auch den SMTP-Traffic überwachen. Lotus Notes verwendet den TCP Port 1352 und SMTP den TCP Port 25.

Vorgehensweise
Es müssen 4 Filter erstellt werden:

Filter 1. ausgehende Lotus Notes Verbindungen.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | TCP | Mein Computer | Jeder | Jede | 1352 | Ja | Zählen |
Filter 2. ausgehende SMTP Verbindungen.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | TCP | Mein Computer | Jeder | Jede | 25 | Ja | Zählen |
Filter 3. eingehende Lotus Notes Verbindungen.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | TCP | Mein Cmputer | 1352 | Jede | Jeder | Ja | Zählen |
Filter 4. eingehende SMTP Verbindungen.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | TCP | Mein Computer | 25 | Jede | Jeder | Ja | Zählen |

Anmerkung

  • Das Beispiel setzt voraus, dass der TrafMeter Dienst auf dem Lotus Notes Server läuft.


TrafMeter :: Beispiel 5

Beispiel 5

Ziel
Sie sind Administrator des Büronetzwerkes. Die PC's in ihrem Netzwerk liegen im Bereich 192.168.3.2-192.168.3.255. Das Büronetzwerk ist über einen NAT-Router mit der IP 192.168.3.1 mit dem Internet verbunden. Sie wollen nun den Internet-Traffic jedes einzelnen ihrer Büro-PC's überwachen. Traffic innerhalb des Büronetzwerkes soll nicht erfasst werden.

Vorgehensweise
Folgende Schritte sind nötig:
- Die Definition der Lokalen Adresstabelle (LAT) mit dem Bereich 192.168.3.1-192.168.3.255
- Für jede Arbeitsstation muss ein eigener Filter erstellt werden

Filter 1. Internet Traffic des PC 192.168.3.2.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | 192.168.3.2 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 2. Internet Traffic des PC 192.168.3.3.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | 192.168.3.3 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 3. Internet Traffic des PC 192.168.3.4.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | 192.168.3.4 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 4. Internet Traffic des PC 192.168.3.5...
Filter 5. Internet Traffic des PC 192.168.3.6...

Anmerkung

  • In diesem Beispiel sollte kein DHCP Server verwendet werden, da sich bei DHCP die IP Adressen ändern können. Wenn Sie einen DHCP Server verwenden, sollten Sie statt der IP-Adressen die MAC-Adressen der PC's verwenden.
  • Bei dieser Konfiguration kann der TrafMeter Dienst entweder am Server oder auf einem der Büro-PC's installiert werden. Siehe "TrafMeter Installation Guide" für Details.
  • Auf Rechnern auf denen NAT läuft, sollte der Aktive Verarbeitungsmodus verwendet werden.


TrafMeter :: Beispiel 6

Beispiel 6 (entspricht Beispiel 5 mit einer zusätzlichen Einstellung)

Ziel
Sie sind Administrator des Büronetzwerkes. Die PC's in ihrem Netzwerk liegen im Bereich 192.168.3.2-192.168.3.255. Das Büronetzwerk ist über einen NAT-Router mit der IP 192.168.3.1 mit dem Internet verbunden. Sie wollen nun den Internet-Traffic jedes einzelnen ihrer Büro-PC's überwachen. Traffic innerhalb des Büronetzwerkes soll nicht erfasst werden. Ausserdem wollen Sie noch Folgendes erfassen:

- den gesamten Internettraffic des Büronetzwerkes erfassen
- den Internetzugriff eines speziellen PC sperren, wenn der PC das Limit von 50MB Internettraffic erreicht hat

Vorgehensweise:
- TrafMeter sollte auf dem NAT PC (PC mit Internetzugang) installiert werden
- Beide vorhandenen Netzwerkadapter müssen für die Verarbeitung markiert werden (also sowohl der Adapter zum Büronetzwerk, als auch der Adapter mit der Internetverbindung)
- den aktiven Verarbeitungsmodus wählen
- die lokale Adressetabelle (LAT) mit dem Bereich 192.168.3.1-192.168.3.255 erstellen
- Filter für jeden einzelnen Büro-PC erstellen

Anmerkung

  • In diesem Beispiel wird der Traffic von 2 Netzwerkadaptern gleichzeitig verarbeitet. Somit sollte darauf geachtet werden, die selben Pakete nicht zweimal zu zählen. Um dies zu erreichen, wird der Traffic des Adapters, der mit dem Internet verbunden ist, via MAC-Adresse erfasst. Nehmen wir an, die MAC Adresse lautet 010203040506:
Filter 1. Der gesamte Internettraffic des Büronetzwerkes
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | MAC: 010203040506 |  | IP Adressen des WAN |  | Ja | Zählen und Durchlassen |
Filter 2. Internettraffic PC 192.168.3.2.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | 192.168.3.2 |  | IP Adressen des WAN |  | Ja | Verweigern | Wenn Sent oder Recv Zähler grösser als 50MB ist
2 | Jedes | 192.168.3.2 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 3. Internettraffic PC 192.168.3.3.
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | 192.168.3.3 |  | IP Adressen des WAN |  | Ja | Verweigern | Wenn Sent oder Recv Zähler grösser als 50MB ist
2 | Jedes | 192.168.3.3 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 4. Internettraffic PC 192.168.3.4...
Filter 5. Internettraffic PC 192.168.3.5...

Anmerkung

  • Die Traffic Zähler können via Administrationskonsole oder dem Kommandozeilntool TrafReset.exe auf 0 zurückgesetzt werden. Mit TrafReset.exe und dem Zeitplandienst ist es möglich, die Werte zurückzusetzen um somit tägliche, wöchentliche oder monatliche Limits zu definieren, die nicht überschritten werden dürfen.
  • In diesem Beispiel sollte DHCP nicht verwendet werden um die IP-Adressen den PC's zuzuordnen.
  • In diesem Beispiel darf der TrafMeter Dienst ausschließlich auf dem Internetzugangsrechner laufen.


TrafMeter :: Beispiel 7

Beispiel 7

Ziel
Sie sind Administrator ihres lokalen Netzwerkes. Die IP's ihrer PC's liegen im Bereich 192.168.3.2-192.168.3.255. Das Netzwerk ist mit dem Internet über einen NAT Router (192.168.3.1) verbunden. Der Gateway besitzt auch einen Proxy Server um Browser im lokalen Netzwerk zu verbinden. Der Proxy Server akzeptiert Verbindungen auf TCP Port 3128. Anderer Internet Traffic (z.B. SMTP, POP3, etc) läuft ausserhalb von NAT. Das Ziel ist den Internettraffic jedes PC's im Netzwerk einzeln zu erfassen. Der Traffic zwischen den PC's im lokalen Netzwerk soll nicht erfasst werden.

Vorgehensweise
Folgende Schritte müssen gemacht werden:
- Definieren Sie die lokale Adresstabelle (LAT) mit dem Bereich 192.168.3.1-192.168.3.255
- Erstellen Sie für jeden PC einen eigenen Filter. Jeder Filter muss 2 Regeln enthalten (eine Regel für Proxy Traffic und eine Regel für NAT Traffic).

Filter 1. Internet Traffic PC 192.168.3.2.
N Regel | IP Protokoll | Ursprungs Adresse | Ursprungs Port | Ziel Adresse | Ziel Port | beide Richtungen | Aktion | Sonstiges
1 | TCP | 192.168.3.2 | Jedes | 192.168.3.1 | 3128 | Ja | Zählen |
2 | Jedes | 192.168.3.2 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 2. Internet Traffic of PC 192.168.3.3.
N Regel | IP Protokoll | Ursprungs Adresse | Ursprungs Port | Ziel Adresse | Ziel Port | beide Richtungen | Aktion | Sonstiges
1 | TCP | 192.168.3.3 | Jedes | 192.168.3.1 | 3128 | Ja | Zählen |
2 | Jedes | 192.168.3.3 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 3. Internet Traffic of PC 192.168.3.4.
N Regel | IP Protokoll | Ursprungs Adresse | Ursprungs Port | Ziel Adresse | Ziel Port | beide Richtungen | Aktion | Sonstiges
1 | TCP | 192.168.3.4 | Jedes | 192.168.3.1 | 3128 | Ja | Zählen |
2 | Jedes | 192.168.3.4 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 4. Internet Traffic PC 192.168.3.5...
Filter 5. Internet Traffic PC 192.168.3.6...

Note

  • In diesem Beispiel sollten Sie den DHCP Dienst nicht verwenden.
  • Der TrafMeter Dienst kann in diesem Beispiel am NAT Router oder auf irgendeinem anderen PC im Netzwerk laufen. Siehe auch TrafMeter Installationsanleitung.
  • Siehe FAQ
  • Auf Rechnern mit NAT sollte der Aktiver Verarbeitungsmodus verwendet werden.


TrafMeter :: Beispiel 8

Beispiel 8

Ziel
Sie sind Administrator eines grossen Internet Service Providers (ISP). Sie haben eine 10Mbit Gatewayverbindung, ungefähr 200 Kunden (sagen wir mal, diese benutzen die IP Adressen 192.168.0.0/24) und 5000-10000 aktive Verbindungen. Sie möchten nun alle Pakete zwischen dem Internet und ihren Kunden aufzeichnen. Was ist die beste Lösung?

Vorgehensweise
In diesem Szenario wäre es sehr mühsam, für jeden Benutzer einen eigenen Filter zu erstellen. Der vernünftigste Weg ist einen Filter zu erstellen, der den Traffic zwischen "ihren Kunden" und dem "WAN" erfasst und das Paket Logging aktiviert:

Filter 1. Internettraffic aller User
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Jedes | 192.168.0.0/24 |  | IP Adressen des WAN |  | Ja | Zählen |

Anmerkung

  • Um das Ziel "IP Adressen des WAN" nutzen zu können, muss die lokale Adresstabelle (LAT) erstellt werden.

Aufgrund der Tatsache das der Paketsammler über eine Grösse von 2000 Positionen verfügt, besteht die Möglichkeit, dass bei einer so grossen Anzahl von gleichzeitigen Verbindungen ein Overflow entsteht. Dies würde bedeuten, dass nicht alle erfassten Pakete auch aufgezeichnet würden. Um dieses Problem zu umgehen, sollten Sie die Frequenz mit der der Paketsammler geleert wird auf 10 Sekunden oder weniger verringern oder eine Art "Load Balancing" für den Paketsammler erstellen. Dies erreicht man dadurch, das man das IP Netz in mehrere logische (nicht physikalische) Netze zerlegt und die Paketaufzeichnung für jedes dieser "logischen" Netzwerke aktiviert. Somit erreicht man quasi eine Vermehrfachung der zur Verfügung stehenden Positionen:

Filter 1. Traffic des logischen Netzes 192.168.0.0/26
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
1 | Any | 192.168.0.0/26 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 2. Traffic des logischen Netzes 192.168.0.64/26
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
2 | Any | 192.168.0.64/26 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 3. Traffic des logischen Netzes 192.168.0.128/26
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
3 | Any | 192.168.0.128/26 |  | IP Adressen des WAN |  | Ja | Zählen |
Filter 4. Traffic des logischen Netzes 192.168.0.192/26
N Regel | IP Protokoll | Ursprung Adresse | Ursprung Port | Ziel Adresse | Ziel Port | Beide Richtungen | Aktion | Sonstiges
4 | Any | 192.168.0.192/26 |  | IP Adressen des WAN |  | Ja | Zählen |

Wenn Sie weiterhin die Nachricht "Packet Collector is full" für einen der Filter erhalten, können Sie das Netz in noch kleinere logische Netze unterteilen (z.B. /28).

Kann man die Grösse des Paketsammlers nicht beliebig vergrössern?

Doch. Aber dies wird nicht viel nützen. Um das Paket in den Paketsammler zu schreiben, muss eine freie Position gefunden werden. Je mehr Positionen vorhanden sind, desto mehr CPU Zyklen braucht die Suche danach.


TrafMeter :: IP Protokoll Nummer

IP Protokoll Nummer

Q0001

Die IP Protokoll Nummer ist 1-Byte langes Feld im IP Protokoll Header. Dieser Wert definiert das höherwertige Protokoll im Datenfeld des Pakets. Nachfolgende Tabelle enthält einige Werte die für spezifische Protokolle oder Organisation fixiert wurden. Diese Werte könnten sich ändern, wenn die Organisation, die diese Definitionen erstellt, dies für nötig hält. Die Internet Assigned Numbers Authority (IANA) ist die Organisation, die dafür verantwortlich ist. Die aktuelle Liste findet man in der RFC 1700.

reservierte Werte im IP Packet Protocol Field
Wert | Protokoll
1 | ICMP
2 | IGMP
3 | GGP
6 | TCP
8 | EGP
17 | UDP
47 | GRE
50 | ESP
51 | AH
89 | OSPF
115 | L2TP


TrafMeter :: Q0002 :: Type Of Service (ToS) Feld

Type Of Service (ToS) Feld

Q0002

The ToS field (1 byte) is used IP protocol suite to describe the desired quality of service for an IP datagram by upper layer protocols like TCP. This field can be used to specify the nature and priority of a IP datagram (like Network Control, Immediate, Critical, etc) and the criteria for selecting a path for forwarding a datagram by a gateway. RFC 1349 discusses the Type Of Service (TOS) field.

Unless you exactly know what you do, don't create rules checking Tos field.


TrafMeter :: Q0003 :: MAC Adresse

MAC Adresse

Q0003

Die MAC Adresse, auch bekannt als physikalische oder Hardware-Adresse, ist eine unverwechselbare Adresse eine Geräts (z.B. einer Netzwerkkarte), die während der Produktion zugeordnet wurde. Normalerweise ist diese Adresse unveränderlich. Diese Adresse wird von der IEEE (Institute of Electronics Engineers) dem Hersteller des Geräts zugeteilt und enthält die Herstellerinformation, sowie eine einmalige Zahl, die vom Hersteller zugeordnet wird.

Eine solche MAC-Adresse sieht folgendermaßen aus: 52-54-AB-20-88-AD. TrafMeter erlaubt es Regeln zu definieren, die mit MAC-Adressen als Ursprungs- oder Zieladresse arbeiten.


TrafMeter :: Q0004 :: Promiskuitiver Modus

Promiskuitiver Modus

Q0004

In einem lokalen Netzwerk ist der "promiskuitive Modus" ein Feature, bei dem jedes übertragene Paket von jedem Netzwerkadapter empfangen und gelesen wird. Dieser Modus muss von jeder Netzwerkkarte genauso unterstützt werden, wie von den Input/Output Treiber des Betriebssystems. Dieser Modus wird vielfach benutzt, um die Netzwerkaktivität zu überprüfen. Wenn im Gegensatz dazu ein Paket im "nicht promiskuitiven Modus" übertragen wird, überprüfen die angeschlossenen Netzwerkgeräte ausschließlich, ob das Paket ihre Adresse als Zieladresse enthält. Wenn dies nicht zutrifft, wird das Paket ohne weitere Bearbeitung an das nächste Netzwerkgerät weitergereicht bis das Gerät mit der entsprechenden Zieladresse erreicht wurde. Dieses Gerät liest und verarbeitet dann das Paket.


TrafMeter :: Q0005 :: Ethernet Hub

Ethernet Hub

Q0005

Ein Ethernet Hub ist ein Gerät, dass es mehreren Geräten erlaubt, im selben Ethernet miteinander zu kommunizieren. Hubs sind ziemlich einfache Geräte, die meist mehrere Ports beinhalten, an die jeweils ein Gerät angeschlossen werden kann. Manchmal ist auch ein zusätzlicher Port enthalten der es erlaubt, weitere Hubs anzuschließen.

Ein Ethernet Hub ist der zentrale Punkte eines kleinen Netzwerkes. Hier laufen alle Geräte wie Arbeitsstation, Netzwerkdrucker und Router zusammen. Dies wird auch als "sternförmige" Verkabelung bezeichnet. Die an die Hub-Ports angeschlossenen Geräte müssen ethernetkompatibel sein, egal ob durch einen eingebauten Ethernertport oder über eine zusätzliche Ethernetkarte. Drucker realisieren dies meist über ein eigenes Zusatzgerät, "Printserver" genannt.

Ein 10BaseT oder 100BaseT Ethernethub (10 oder 100 Mbps Bandbreite über eine Twisted Pair Verkabelung) macht 2 Dinge:

  1. Erneuert oder generiert Ethernet Signale neu, die der Hub von angeschlossenen Geräten erhält
  2. Leitet Ethernet Signale an angeschlossene Geräte weiter

Die Summe aller Bandbreiten der angeschlossenen Geräte ist limitiert auf die Maximalbandbreite des Ethernettyps. D.h. das sich alle angeschlossenen Geräte eines 10BaseT die verfügbaren 10 Mbps teilen müssen. Wenn z.B. 8 Geräte an einem solchen Hub hängen und alle 8 Geräte Datenübertragungen ausführen, stehen pro Gerät nur 1.25 Mbps zur Verfügung. Dies ist der grösste Nachteil der Hubs.


TrafMeter :: Q0006 :: Ethernet Switch

Ethernet Switch

Q0006

Ein Switch erfüllt exakt die gleiche Funktion wie ein Hub und ist äußerlich auch nicht von einem Hub unterscheidbar. Der grosse Unterschied liegt darin, wie der Switch die Datenübertragung der Pakete erledigt. Ein Switch ist intelligent genug um zu erkennen, an welchem Port die Ursprungs- und an welchem Port die Ziel-Adresse zu finden ist. Mit dieser Information kann ein Switch ein Netzwerk ausschließlich zwischen diesen beiden Ports schalten. Solche virtuellen Netzwerke können in fast beliebiger Anzahl geschaltet werden. Der Vorteil ist, dass jedes dieser Netzwerke die Ethernet-Bandbreite zur Verfügung steht. Somit kann ein Switch insgesamt ein Mehrfaches der Ethernet-Bandbreite verarbeiten.

Ethernet Switche arbeiten zwar auch mit dem kollisionsfähgien Ethernetprotokoll aber verhindern diese Kollisionen durch ihre Intelligenz. Im Gegensatz dazu sind Hubs "dumm" und können keine Kollisionen verhindern.


TrafMeter :: Q0007 :: Was ist ein Ethernet

Was ist ein Ethernet?

Q0007

Ethernet arbeitet auf Basis von "Carrier Sense Multiple Access / Collision Detect" oder kurz "CSMA/CD". "Multiple Access" bezieht sich darauf, dass mehrere Computer auf ein einzelnes Ethernet Segment Zugriff haben. Ursprünglich ware damit ein einzelnes Coax Segment gemeint. Jetzt werden damit aber alle Netzwerkgeräte auf der gleichen "Seite" einer Netzwerk Bridge oder eines Switches gemeint. "Carrier Sense" bedeutet, dass jedes Mitglied in einem Ethernet Segment feststellen kann, ob ein anderes Mitglied gerade sendet. Wenn dies der Fall ist, wird keine Übertragung gestartet. Wenn aber zwei Mitglieder mit dem Senden praktisch gleichzeitig beginnen, schützt "Carrier Sense" nicht davor, dass sich beide Übertragungen überlagern. Dies wird auch als "Collision" bezeichnet. Dafür stellt Ethernet das "Collision Detect" Feature bereit. Dies erlaubt es einem Mitglied, die Kollision der eigenen Übertragung mit der Übertragung eines anderen Netzwerkmitgliedes zu erkennen, und erlaubt dem Mitglied, ein Störungssignal an alle Mitglieder im Segment zu senden. Wenn dieses Signal empfangen wird, beenden sofort alle Mitglieder ihre Übertragungen und beginnen mit einem zufällig gewählten Countdown, nach dessen Ablauf die Übertragung erneut versucht wird.


TrafMeter :: Q0008 :: NAT Router

NAT Router

Q0008

Ein NAT Router ist ein PC oder ein eigenständiges Gerät das über mindestens 2 Netzwerkanschlüsse verfügt.

NAT steht für Network Address Translation und ermöglicht einen transparenten Zugriff eines gesamten IP Netzwerkes über eine einzelne öffentlich erreichbare IP Adresse. Dabei haben aber alle Computer eine eigene IP Adresse. Bei Internetverbindungen dieser Computer erscheint aber stets die selbe öffentliche IP Adresse als Urspung bzw. Zieladresse.

In Windows 2000 kann ein NAT Router über die Eigenschaften der Netzwerkverbindung definiert werden oder - bei Windows 2000 Server - über das AD-Snap-In "Routing and Remote Access".

In Windows XP kann das NAT Routing über "Erweitert" in den Eigenschaften der Netzwerkverbindung aktiviert werden.

Ausserdem gibt es für Microsoft Windows noch NAT Lösungen von Drittanbietern.


TrafMeter :: Q1000 :: HOWTO: Einen OLE DB InitString für Microsoft SQL Server erzeugen

HOWTO: Einen OLE DB InitString für Microsoft SQL Server erzeugen

Q1000

Achtung! Die MS SQL Server Datenbank muss existieren, bevor der InitString erstellt werden kann.

  1. Den UDL Assistenten starten:
    • Erzeugen Sie mit einem Rechtsklick auf den Desktop ein neues Textdokument.
    • Benennen Sie das Dokument in My.udl um. Drücken Sie ENTER.
    • Sie werden eine Warnung bzgl. der Umbennung erhalten. Klicken Sie auf Ja.
  2. Doppelklicken Sie My.udl und benutzen Sie den Assistenten folgendermaßen:
    • Klicken Sie auf "Provider".
    • Wählen Sie den "Microsoft OLE DB Provider for SQL Server" und klicken Sie auf "Weiter".
  3. Auf "Verbindung":
    • Geben Sie den Datenbankserver ein.
    • Geben Sie benötigen Anmeldedaten ein.
    • Wählen Sie die gewünschte Datenbank aus.
    • Klicken Sie auf "Verbindung testen" um sicherzustellen, dass kein Fehler gemacht wurde.
    • Klicken Sie auf "OK", um den Assistenten zu beenden.
  4. Verschieben Sie die Datei My.udl vom Desktop in einen anderen Ordner, z.B. C:\Programme\TrafMeter


TrafMeter :: Q1002 :: HOWTO: Einen OLE DB InitString für Microsoft Access 97/2000/XP erstellen

HOWTO: Einen OLE DB InitString für Microsoft Access 97/2000/XP erstellen

Q1002

Achtung! Die MS Access Datenbank muss existieren, bevor der Verbindungsstring erstellt werden kann.

  1. Den UDL Assistenten starten:
    • Erzeugen Sie mit einem Rechtsklick auf den Desktop ein neues Textdokument.
    • Benennen Sie das Dokument in My.udl um. Drücken Sie ENTER.
    • Sie werden eine Warnung bzgl. der Umbennung erhalten. Klicken Sie auf Ja.
  2. Doppelklicken Sie My.udl und benutzen Sie den Assistenten folgendermaßen:
    • Klicken Sie auf "Provider".
    • Wählen Sie den "Microsoft Jet 4.0 OLE DB Provider" und klicken Sie auf "Weiter".
  3. Auf "Verbindung":
    • Geben Sie den Datenbankserver ein.
    • Geben Sie benötigen Anmeldedaten ein.
    • Wählen Sie die gewünschte Datenbank aus.
    • Klicken Sie auf "Verbindung testen" um sicherzustellen, dass kein Fehler gemacht wurde.
    • Klicken Sie auf "OK", um den Assistenten zu beenden.
  4. Verschieben Sie die Datei My.udl vom Desktop in einen anderen Ordner, z.B. C:\Programme\TrafMeter


TrafMeter :: Q1010 :: HOWTO: Einen OLE DB Verbindung String für MySQL Server erstellen

HOWTO: Einen OLE DB Verbindung String für MySQL erstellen

Q1010

Downloaden Sie von www.mysql.com den aktuellen MySQL ODBC Driver. Die Datenbank muss existieren, bevor der UDL Assistent benutzt werden kann.

  1. Den UDL Assistenten starten:
    • Erzeugen Sie mit einem Rechtsklick auf den Desktop ein neues Textdokument.
    • Benennen Sie das Dokument in My.udl um. Drücken Sie ENTER.
    • Sie werden eine Warnung bzgl. der Umbennung erhalten. Klicken Sie auf Ja.
  2. Doppelklicken Sie My.udl und benutzen Sie den Assistenten folgendermaßen:
    • Klicken Sie auf "Provider".
    • Wählen Sie den "Microsoft OLE DB Provider for ODBC drivers" und klicken Sie auf "Weiter".
  3. Auf "Verbindung":
    • Klicken Sie auf "Erstellen" unter "Verbindungszeichenfolge verwenden" .
    • Klicken Sie auf "Neu..." auf dem Reiter "Dateidatenquelle". Es öffnet sich ein Fenster "Neue Datenquelle erstellen". Wählen Sie den "MySQL ODBC 3.x Driver" und klicken Sie auf "Weiter".
    • en Sie dieser neuen Datenquelle (DSN) einen Namen, z.B. "mysql_linux" und klicken Sie auf "Weiter". Im nächsten Fenster klicken Sie wiederum auf "Weiter".
    • Geben Sie einen Hostnamen oder eine IP Adresse für den MySQL, einen Datenbanknamen, einen Usernamen und ein Passwort ein. Wählen Sie "Verbindung testen" um die Korrektheit aller eingegebenen Daten zu überprüfen.
    • Bestätigen Sie die Angaben und kehren Sie zur Anwendung "Datenverknüpfungseigenschaften" zurück und sichern Sie mit einem Klick auf "OK" die Einstellungen.


TrafMeter :: Von Version 3.x upgraden

Von Version 3.x upgraden

Q2000

TrafMeter 4.x kann die TrafMeter 3.x Konfiguration lesen, aber folgendes sollte beachtet werden:

  • Wenn Sie Trafmeter nach dem 10.11.2003 erworben haben, erhalten Sie TrafMeter 4.1 kostenlos mit der Einschränkung, dass die Benutzung auf 1 Filter beschränkt ist. Die Anforderung für einen neuen Key können Sie uns in jeder beliebigen Art und Weise zusenden
  • Machen Sie ein Backup ihres aktuellen Filtersatzes und der XML Traffic Berichte bevor Sie upgraden
  • Deinstallieren Sie TrafMeter 3.x
  • Installieren Sie TrafMeter 4.x und fügen Sie den Registrierungsschlüssel hinzu
  • Laden Sie den TrafMeter 3.x Filtersatz in TrafMeter 4.x
  • Beachten Sie, das standardmäßig alle Regeln des 3.x Filtersatzes auf die Aktion "Zählen" gesetzt werden.
  • Die Vorfilter in TrafMeter 3.x sind in TrafMeter 4.x nicht enthalten. "Vorfilter" können Sie mit Regeln und der Aktion "Durchlassen" in TrafMeter 4.x erstellen.
  • TrafMeter 3.x benutzt eine Dateinamenvorlage für die XML Traffic Berichte. Die neue Version hat diese Option nicht inkludiert. Für Näheres beachten Sie bitte XML Traffic Berichte.
  • Die Einstellungen für das Aufzeichnen des Traffics in Datenbanken wurde vereinfacht. Statt der Zeitformatvorlage sollten Sie nun das Feld "Traffic Sample" benutzen. Details finden Sie hier.


TrafMeter :: Q2001 :: manuelles Ändern der XML Dateien

manuelles Ändern der von TrafMeter erzeugten XML Dateien

Q2001

TrafMeter benutzt das XML Format als Grundformat für das Speichern der Konfiguration und die Erstellung von Berichten. Seien Sie als vorsichtig wenn Sie die von TrafMeter erzeugten XML Dateien mit Fremdprodukten ändern, da TrafMeter die Dokument mit UTF-8 Kodierung erstellt.

UTF-8 kodiert jedes Unicodezeichen als variable Nummer bestehend aus 1 bis 6 Oktetten, wobei die Anzahl der Oktetten abhängig vom Integerwert des Unicodezeichens ist. Dies ist ein effiziente Art Unicodedokumente zu kodieren, die hauptsächlich US-ASCII Zeichen enthalten, da die Werte von U+0000 bis U+007F mit einem einzelnen Oktett kodiert werden können.

Anmerkung

  • Benutzen Sie keine Texteditoren die keine UTF-8 Kodierung unterstützen (ES-Computing Editplus, FAR Manager built-in editor, etc)
  • Benutzen Sie ausschließlich Editoren mit UTF-8 Unterstützung (Altova XML Spy, Microsoft Visual Studio .NET, etc)

Es wird dringend angeraten, ein modifiziertes XML Dokument nach der Änderung im Microsoft Internet Explorer für eine Überprüfung zu öffnen.


TrafMeter :: XML Traffic Berichte :: Beispiel für monatlichen Bericht

Beispiel für einen monatlichen XML Traffic Bericht

<?xml version="1.0"?>
<TrafficReport>
    <Filter Id="15">
        <Name>POP3 traffic</Name>
        <Sent>2518192</Sent>
        <Recv>12315902</Recv>
        <Day dt="030822">
            <Sent>677994</Sent>
            <Recv>3510996</Recv>
        </Day>
        <Day dt="030823">
            <Sent>1229603</Sent>
            <Recv>7758167</Recv>
        </Day>
        <Day dt="030824">
            <Sent>610595</Sent>
            <Recv>1046739</Recv>
        </Day>
    </Filter>
</TrafficReport>